1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 High PHP Loads

Discussion in 'Troubleshooting and Problems' started by trichome, Jun 22, 2013.

  1. trichome

    trichome Member

    I'm having issues with php5-cgi processes maxing out CPU. Started happening today, I haven't changed anything recently though.

    If I de-activate the board the load drops down to normal.

    XenForo 1.1.5

    I've disabled all add-ons with no effect.

    FluxBB 1.4 Importer (by Code In Motion)
    Nodes As Tabs
    Photo CAPTCHA
    Self Lock
    Theme Information

    4 errors from today in the server error log all at the same time:
    Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    Today at 1:36 PM - library/Zend/Db/Adapter/Mysqli.php:333

    Any ideas would be appreciated.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Can't connect to local MySQL server through socket
    Generic mysql connect error. The db server was down or unresponsive.

    What kind of server? Dedi, VPS, or shared?

    Ideally your host can check the logs and active processes to narrow down the problem. Otherwise you will need to submit a ticket with all logins so we can take a look.
  3. trichome

    trichome Member

    It's a VPS. The host said that everything on their end looks fine. They said that "there was someone abusing the disk i/o on the server for a short time earlier today which may have caused your vps to be unresponsive".

    Using the top command, it's php5-cgi that's using all the CPU. Which logs would you recommend looking through?

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    So the problem was some one else on the server? Not you?
  5. trichome

    trichome Member

    That's right, I wasn't the one abusing the disk i/o. It was someone on the same box though. I don't know if that is related to this issue.
  6. trichome

    trichome Member

    I upgraded my php version to this ppa and load is back to normal.
    Jake Bunce likes this.
  7. trichome

    trichome Member

    Well it was back to normal for 30 minutes. Now mysqld is choking the cpu.

    Edit: I restarted mysql and now it's php going nuts again. Does anyone see anything terribly wrong here? I just turned on the slow query log and it's empty so far. Again, if I close the board the problem goes away.


    Here's my.cnf.

    # The MySQL database server configuration file.
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    # For explanations see
    # http://dev.mysql.com/doc/mysql/en/server-system-variables.html
    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    port        = 3306
    socket        = /var/run/mysqld/mysqld.sock
    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram
    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    socket        = /var/run/mysqld/mysqld.sock
    nice        = 0
    # * Basic Settings
    #  If you make changes to these settings and your system uses apparmor, you may
    #  also need to also adjust /etc/apparmor.d/usr.sbin.mysqld.
    user        = mysql
    socket        = /var/run/mysqld/mysqld.sock
    port        = 3306
    basedir        = /usr
    datadir        = /var/lib/mysql
    tmpdir        = /tmp
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    bind-address        =
    # * Fine Tuning
    key_buffer        = 16M
    max_allowed_packet    = 16M
    thread_stack        = 192K
    thread_cache_size      = 8
    # This replaces the startup script and checks MyISAM tables if needed
    # the first time they are touched
    myisam-recover        = BACKUP
    #max_connections        = 100
    #table_cache            = 64
    #thread_concurrency    = 10
    # * Query Cache Configuration
    query_cache_limit    = 1M
    query_cache_size        = 0
    # * Logging and Replication
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    # As of 5.1 you can enable the log at runtime!
    #general_log_file        = /var/log/mysql/mysql.log
    #general_log            = 1
    log_error                = /var/log/mysql/error.log
    # Here you can see queries with especially long duration
    log_slow_queries    = /var/log/mysql/mysql-slow.log
    long_query_time = 2
    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    #      other settings you may need to change.
    #server-id        = 1
    #log_bin            = /var/log/mysql/mysql-bin.log
    expire_logs_days    = 10
    max_binlog_size        = 100M
    #binlog_do_db        = include_database_name
    #binlog_ignore_db    = include_database_name
    # * InnoDB
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    # * Security Features
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    # For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem
    max_allowed_packet    = 16M
    #no-auto-rehash    # faster start of mysql but no tab completition
    key_buffer        = 16M
    # * IMPORTANT: Additional settings that can override those from this file!
    #  The files must end with '.cnf', otherwise they'll be ignored.
    !includedir /etc/mysql/conf.d/
    Last edited: Jun 22, 2013
  8. Slavik

    Slavik XenForo Moderator Staff Member

    You have no innodb config, which can help massively.

    To start with, get a good sized buffer pool, file per table and flushing enabled for trx commit.
  9. trichome

    trichome Member

    Thanks Slavik. I'm sure there's a lot of room for improvement. I think there's something else going on as well since it has been working fine with low load for months until yesterday.

Share This Page