1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help regarding import from vBulletin 4.0.6

Discussion in 'Installation, Upgrade, and Import Support' started by Saeed, Jul 19, 2011.

  1. Saeed

    Saeed Well-Known Member

    Hi guys. :)

    After waiting for a very long time, I think that I can finally port over my forums from vBulletin 4 to XenForo.

    I read Jake's article on the import, twice actually and after checking around, started off.

    I was able to import several steps without a hitch and things were running pretty smooth. Then during the import of threads and posts (about 15-20 mins since the start of this step), I got an error message saying:

    The page cannot be displayed because an internal server error has occurred.

    I was a bit perplexed, since this was unexpected. May I mention here that before starting the import, which is still a test import, when I turned the forums status to off, I was getting the same error when trying to access the forum as a visitor. Signing into the Admin CP however would allow me in normally.

    Anyhow, I thought I'd start over again. So I accessed the Admin CP and went to Tools > Import, where it showed that there was an import already in progress and that I could continue or start afresh. When I try to continue, it still gives me the same error. :confused:

    May I add: The only change I made to the default XenForo installation was change the logo, change the maximum character count in a post to unlimited and enable fully friendly URLs, along with the web.config file required for our IIS server, as mentioned here.

    I would be grateful if someone could kindly help me out with this a bit.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Can you right click on the page and view source?
    That may provide more information on the error.

    Is there anything in the apache logs, ACP logs or even a log file on the server?
  3. Saeed

    Saeed Well-Known Member

    Thank you Paul for replying. :)

    Yes, I did check the log error, and it helped. Apparently, there are posts and threads with characters such as " in the titles, which seems to be creating problems. Is there any way I could prune / clean such characters in my vBulletin database? Any SQL query perhaps?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Those characters shouldn't be a problem, the importer should be able to deal with them.

    You can quite safely create a thread in XenForo using this as the title: "!$'#~}{][)(*&^%$

    All that will happen is the thread URL is only given an id and no text string, e.g. http://localhost/xftest/threads/.3187/

    Have any issues related to this been reported on the 4.x importer thread?
  5. Saeed

    Saeed Well-Known Member

    That's a pretty long thread. :D Let me see if I can find something though.

    Thank you once again, Paul. :)
  6. Saeed

    Saeed Well-Known Member

    OK, thought I'd update over here.

    I had a look at the vB 4.x importer thread and there wasn't anything similar like that mentioned over there. For the moment being, all database entries which were causing trouble were simply deleted. We had already ported over from Cold Fusion to vBulletin a few years back and we just couldn't see any point in carrying around any more database problems.

    At the moment, I have two queries.

    1. When I turn off the forums and view it as an unregistered user, instead of seeing the placeholder message from the Admin CP, I get the error: The page cannot be displayed because an internal server error has occurred.

    2. I have several threads which had Urdu characters in their titles, and although they seem to be imported correctly, when I try to open any such threads, I get the same error as above, i.e. The page cannot be displayed because an internal server error has occurred.

    Is this perhaps because XenForo still does not have right-to-left language support? If that is so, and I keep these imported threads as it is for now, when I upgrade to 1.1 (which would have right-to-left language support), would all these threads be accessible after the upgrade?

    Any help would be appreciated. :)
  7. Brogan

    Brogan XenForo Moderator Staff Member

    RTL doesn't really have anything to do with URLs (apart from the obvious links to language) and as you can see, it should work fine:



    You shouldn't be getting the internal server error so we need to get to the bottom of that.
    You mentioned that the problem occurs when you turn the forums off.
    What happens when you open the forum?
  8. Saeed

    Saeed Well-Known Member

    Yeah, Paul, you're right. I just created a thread with Urdu characters here in the Test forums and it shows correctly.

    If I open the forum, everything appears and works fine. That's what's bugging me. I played around with a test installation a couple of months back and it was perfectly fine. Perhaps some server settings? :confused:
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Hmmm, so it works fine when the forum is open, and reports server errors when it's closed?
    That's a new one...

    Is this on a public domain, or local host?

    Can you PM the link and an admin login so I can have a quick look?
  10. Saeed

    Saeed Well-Known Member

    Sure thing, Paul. Just sent you a PM. :)
  11. Brogan

    Brogan XenForo Moderator Staff Member

    I just had a quick look at a few things.

    I turned friendly URLs off and it no longer seems to be erroring.
    Can you confirm that's the case?

    That then tells us where to start looking.
  12. Saeed

    Saeed Well-Known Member

    Turning off Friendly URLs fixes the error message I was getting when I would turn the forums off, yes. (y)

    It also shows the threads with the Urdu characters in their titles without an error. (y) x 2

    But it still shows an error when I try to visit the URL to make a user an administrator: http://site.com/admin.php?admins/ :confused:
  13. Saeed

    Saeed Well-Known Member

    Sorry, let me correct that. Turning off the forums, even with friendly URLs off, is giving the error when I browse as a visitor.
  14. Brogan

    Brogan XenForo Moderator Staff Member

    Ah yes, the problem is still occurring.

    I've just run a file health check and all is OK there.

    At this point I think it's best if you open a ticket as it will require server access and debugging.
  15. Saeed

    Saeed Well-Known Member

    I've submitted a ticket. :)
  16. Digital Doctor

    Digital Doctor Well-Known Member

    What ended up being the problem ?
  17. Saeed

    Saeed Well-Known Member

    If I remember correctly, it was some non-ASCII characters which had somehow become part of the database after a ColdFusion to vBulletin import.

Share This Page