1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Help on a phpbb import

Discussion in 'Installation, Upgrade, and Import Support' started by niros_1234, Aug 26, 2013.

  1. niros_1234

    niros_1234 Member


    I am trying to import a phpbb forum and i have the following problems:

    a) when rebuilding the cache i got
    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Got error 28 from storage engine - library/Zend/Db/Statement/Mysqli.php:214

    Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Got error -1 from storage engine - library/Zend/Db/Statement/Mysqli.php:214

    Should i worry about these?

    b) I placed my forum in a folder www.something.com/forums
    how when i visit a category the url shows www.something.com/forums/forums/

    how can I make it so it's not doubled the "forums" folder?
    Of course... without installing the forum in the root of the domain.

    Thank you.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Error 28 means the disk is full.

    You will need to create some space (deleting logs for example) or get a larger disk.

    The /forums route can be changed by renaming the installation path/directory or using the Route Filter function in the ACP.
  3. niros_1234

    niros_1234 Member


    thank you for the answer.

    I am on a justhost host so... i have unlimited space on disk and on db.

    and ... the page route requires me to enter a replace that can't be void...
    In order to remove the second "forums/" i was thinking of doing a route filter like
    "forums/" to "/" but it doesn't allow me to.
    Other solution to this?

    I repeat my problem:
    I want my forum links to look like "www.something.com/forums/forum-name/forum-topic/"
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    You cannot remove routes via route filters, only modify them.

    There is no such thing as unlimited disk space, you should contact your host to resolve the Error 28s.
  5. MattW

    MattW Well-Known Member

    There is no such thing as unlimited space.
  6. Nysm

    Nysm Member

    I like to refer to it as "unmetered".

    Which in some cases it's "We don't care how much you use, just as long as it's not suspicious and makes our service slow".
  7. niros_1234

    niros_1234 Member

    ok. guys. solved the problems.

    Just one more thing remaining...
    The redirect scripts... from old phpbb links to the new xenforo ones.

    I understand that I must add something to the htacces file in the forum directory.

    The situation is:
    Old forum link: www.something.com/forum
    The new forum: link www.something.com/forum
    When the import was done the IDs where kept.

    Can someone please tell me what are the exact line I must add in the .htaccess file and where (after what lines of code)?

    i read the info here http://xenforo.com/community/threads/phpbb-to-xf.55517/
    but it's not clear to me what are the lines for my exact configuration.

    Thank you.
  8. Mike

    Mike XenForo Developer Staff Member

    These should work for you, based on what's in that thread.

    RewriteCond %{QUERY_STRING} (^|&)t=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /forum/threads/%2? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} f=(\d+)$ [NC]
    RewriteRule ^(viewforum\.php|viewtopic\.php)$ /forum/forums/%1? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} (^|&)p=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /forum/posts/%2? [L,R=301,NC]
    maszd, niros_1234 and RoldanLT like this.
  9. niros_1234

    niros_1234 Member

    Thanks Mike.
    i will try it and let you know.
  10. niros_1234

    niros_1234 Member

    it doesn't work.

    My htaccess file is this

    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
        RewriteEngine On
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        #RewriteBase /xenforo
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    RewriteCond %{QUERY_STRING} (^|&)t=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /forum/threads/%2? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} f=(\d+)$ [NC]
    RewriteRule ^(viewforum\.php|viewtopic\.php)$ /forum/forums/%1? [L,R=301,NC]
    RewriteCond %{QUERY_STRING} (^|&)p=([0-9]+)(&|$) [NC]
    RewriteRule ^viewtopic\.php$ /forum/posts/%2? [L,R=301,NC]
    What is wrong ? :)
  11. Mike

    Mike XenForo Developer Staff Member

    The conditions are too low. They need to be above:

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    niros_1234 likes this.
  12. niros_1234

    niros_1234 Member

    ok. super...
    it all works now...
    Thank you very much

Share This Page