[HELP ]How to use url rewrite with 1 & 1?

VG_AzR

Active member
Hello, I can not use the rewrite of url with the host: 1 & 1. I am under APACHE

The mod_rewrite is activated on their server, but when I activate the rewrite of url via admin.php? Options / groups / basicBoard /, I absolutely can not do anything on my forum.

http://prntscr.com/i9acnu


I try to adapt the .htaccess but always the same ...

I use the basic xenforo htaccess


Thank you for helping me
 

Brogan

XenForo moderator
Staff member
Ask your host to check the server error log to see what is triggering the 500 error.
 

ŽivaAkcija

Well-known member
you need to rename htaccess file to %22.htaccess%22 or "htaccess" if i remeber?

<IfModule mod_rewrite.c>
RewriteEngine On

# If you are having problems with the rewrite rules, remove the "#" from the
# line that begins "RewriteBase" below. You will also have to change the path
# of the rewrite to reflect the path to your XenForo installation.
#RewriteBase /xenforo

# This line may be needed to enable WebDAV editing with PHP as a CGI.
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
</IfModule>

that is my setup
 

Tracy Perry

Well-known member
Simply renaming the htaccess.txt to .htaccess generally works.
If you have edited the htaccess file, what did you use to edit and save it with?
 

VG_AzR

Active member
Thank you for the return, I edited with the notepad.
It turns out that simply renaming is not enough
 

VG_AzR

Active member
I finally found the solution, I also leave the solution if it ever happened to others :)

Code:
Options +FollowSymLinks

RewriteEngine On

RewriteBase /

#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
 

Tracy Perry

Well-known member
You shouldn't be editing with notepad on a windows machine.
You should use something like NotePad++ or similar.
 
Top