1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Having issue with installation

Discussion in 'Troubleshooting and Problems' started by Staxed, Sep 26, 2012.

  1. Staxed

    Staxed Active Member

    I recently moved to a new server and apparently something somewhere is conflicting with Xenforo.

    The one forum I transferred over isn't working, and I'm getting an error when I try to install a new one as well. I have a support ticket opened but figured I'd see if anyone else can help while I wait for a response.

    I've checked on the forums, and tried everything in the threads I found (http://xenforo.com/community/threads/upgrading-server.30960/ and http://xenforo.com/community/threads/installation-error-for-latest-version-1-1-3.33560/#post-382655)

    Steps I've taken:
    • Upgraded to most recent php version (5.3.17)
    • Made sure mysql and mysqli extentions are updated
    • updated Zend Guard
    • cleared the entire database after every try to insure that wasn't the issue with each change.
    • set php_admin_value[memory_limit] = 128M
    • set php_admin_value[post_max_size] = 8M
    • set php_admin_value[upload_max_filesize] = 8M
    • set mysql packet size to 64M
    any ideas on what else I can try?
    ----------
    Code:
    [SIZE=5][B][FONT=Trebuchet MS][SIZE=16px]Server Error[/SIZE][/FONT][/B][/SIZE]
    
    [SIZE=13px][FONT=Trebuchet MS]unserialize() [<a href='function.unserialize'>function.unserialize</a>]: Error at offset 0 of 1 bytes[/FONT][/SIZE]
    [LIST=1]
    [*][B]XenForo_Application::handlePhpError()[/B]
    [*][B]unserialize()[/B] in [B]XenForo/Model/StyleProperty.php[/B] at line [B]667[/B]
    [*][B]XenForo_Model_StyleProperty->updatePropertyCacheInStyle()[/B] in [B]XenForo/Model/StyleProperty.php[/B] at line [B]632[/B]
    [*][B]XenForo_Model_StyleProperty->rebuildPropertyCacheInStyleAndChildren()[/B] in [B]XenForo/Model/StyleProperty.php[/B] at line [B]2316[/B]
    [*][B]XenForo_Model_StyleProperty->importStylePropertiesFromArray()[/B] in [B]XenForo/Model/StyleProperty.php[/B] at line [B]2187[/B]
    [*][B]XenForo_Model_StyleProperty->importStylePropertyXml()[/B] in [B]XenForo/Model/StyleProperty.php[/B] at line [B]2120[/B]
    [*][B]XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml()[/B] in [B]XenForo/CacheRebuilder/ImportMasterData.php[/B] at line [B]45[/B]
    [*][B]XenForo_CacheRebuilder_ImportMasterData->rebuild()[/B] in [B]XenForo/ControllerHelper/CacheRebuild.php[/B] at line [B]26[/B]
    [*][B]XenForo_ControllerHelper_CacheRebuild->rebuildCache()[/B] in [B]XenForo/Install/Controller/Install.php[/B] at line [B]240[/B]
    [*][B]XenForo_Install_Controller_Install->actionStep2b()[/B] in [B]XenForo/FrontController.php[/B] at line [B]310[/B]
    [*][B]XenForo_FrontController->dispatch()[/B] in [B]XenForo/FrontController.php[/B] at line [B]132[/B]
    [*][B]XenForo_FrontController->run()[/B] in [B]/home/account/public_html/jsm/install/index.php[/B] at line [B]18[/B]
    [/LIST]
    
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Staxed

    Staxed Active Member

    I tried everything in that and things still aren't working.

    Xenforo says my server is good, I've reinstalled php, my libraries are up to date (at least support says they are, anyone know how to check this myself...I have root access, I just don't know how to check this). I've tried everything I could find in all the threads I could find, and I'm still getting this error.

    I'm ready to pull my hair out, I have no clue what else to do.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Based on my experience with this error it is definitely a server issue. The MySQL client libraries in PHP are suspect. Upgrading those libraries has fixed the problem for other people. As I said in this post:

    http://xenforo.com/community/threads/migration-issue.35809/#post-407640

    ...there isn't a specific bug that I have identified with MySQL. Rather it's process of elimination. I have confirmed the data is correct in XenForo up to the point when the query is handed to MySQL. Mike also confirmed this.
     
  5. Staxed

    Staxed Active Member

    Yeah, that's just the thing, I've done all of that, and everything looks like it's up to date, which is what I don't understand.

    Though, I don't actually know the process for updating the libraries (hard to find information on that apparently...or i'm just looking in the wrong places), it says they are 5.0.95
     
  6. Adam Howard

    Adam Howard Well-Known Member

    Back up the database
    Back up the database again
    Back up the database once more ...... You'll be updating MySQL and possibly removing it to re-install ..... You want to be sure you have a back up.

    You're also maybe going to make peace with php 5.4.x I help someone try to get past this on php 5.3 and it never worked. 5.4 was the solution.

    If what you say is true... Something hasn't updated....

    If Debian or Ubuntu (and not using a control panel)

    PHP:
    aptitude update
    PHP:
    aptitude full-upgrade
    If you noticed any updates applied .... Reboot.

    Repeat the above process until there are no more updates. If this doesn't fix it.... Time for more work

    PHP:
     nano /etc/apt/sources.list 
    Makes sure this is there (add as needed)

    PHP:
    # Debain Main Update
    deb http://ftp.de.debian.org/debian stable main contrib non-free
    deb-src http://ftp.de.debian.org/debian stable main contrib non-free
     
    deb http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
    deb-src http://ftp.debian.org/debian/ squeeze-updates main contrib non-free
     
    deb http://security.debian.org/ squeeze/updates main contrib non-free
    deb-src http://security.debian.org/ squeeze/updates main contrib non-free
     
    #Debian Backport
    deb http://backports.debian.org/debian-backports squeeze-backports main
     
    #Dotdeb.org
    deb http://packages.dotdeb.org squeeze all
    deb-src http://packages.dotdeb.org squeeze all
     
    #Dotdeb.org php 5.4
    deb http://packages.dotdeb.org squeeze-php54 all
    deb-src http://packages.dotdeb.org squeeze-php54 all
    SAVE, EXIT

    PHP:
      wget http://www.dotdeb.org/dotdeb.gpg
    cat dotdeb.gpg sudo apt-key add 
    PHP:
    aptitude update
    PHP:
    aptitude full-upgrade
    This should update everything

    PHP:
     /etc/init.d/apache2 restart 
    You may need to reboot.

    If this doesn't work..... Something is wrong with your configuration.

    Back up your configuration files for PHP and MySQL. Place them aside. You're not going to use them for now.

    This is where thinks get ugly... Sorry.

    PHP:
    aptitude purge mysql-server mysql-client php5 php5-fpm libapache2-mod-php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
    PHP:
     /etc/init.d/apache2 restart 
    PHP:
    aptitude install mysql-server mysql-client php5 php5-fpm libapache2-mod-php5-mysql php5-curl php5-gd php5-intl php-pear php5-imagick php5-imap php5-mcrypt php5-ming php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl
    PHP:
     /etc/init.d/apache2 restart 
    You may need to reboot

    You should now have a fresh install of MySQL and Php (both newest versions).

    Restore your database. It may have been wiped out during the purge (most likely). This is why you were told to back it up (several times). If you didn't.... Not my fault.

    All should be working now :)
     
    Jake Bunce and Staxed like this.
  7. Staxed

    Staxed Active Member

    thanks for that, i'll have to look into it. Sadly this site isn't the only thing on this server (only 3 other sites right now though), so I guess backing up everything and giving this a shot won't hurt much.

    Really appreciate the steps! :D
     
  8. Adam Howard

    Adam Howard Well-Known Member

    WAIT.

    If the other 3 sites are not yours and you're hosting someone else.... Make sure to back up everything. Including their databases as well.

    Just good advice (and also responsible thing to do)
     
  9. Staxed

    Staxed Active Member

    I said I was going to back it all up in the previous post :D, they are all my sites though, so no worries there. Thanks for the concern though! :D
     
    Adam Howard likes this.
  10. Adam Howard

    Adam Howard Well-Known Member

    I read it... Sorry.... I get worried about such things. :p

    If you need any help though.... I'm always willing to lend a hand :)
     
  11. Staxed

    Staxed Active Member

    well hopefully you are still around these days.

    I took a long break from doing things and am actually just not getting around to doing this. And now I realize that you gave instructions for Debian/Ubuntu...my server runs on CentOS. Do you (Adam/Anyone) happen to know the equivalent process for CentOS?
     
  12. Staxed

    Staxed Active Member

    problem solved, must have been something with the libraries (I swear I had them updated multiple times).

    I just upgraded to mysql 5.1 and seems like my issues are fixed.
     
    Adam Howard and Jake Bunce like this.

Share This Page