1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

H2 Changed to Span

Discussion in 'Styling and Customization Questions' started by LPH, Nov 12, 2012.

  1. LPH

    LPH Well-Known Member

    Whenever a post in WordPress is placed inside XenForo (XenScripts), the H2 tag is changed to a span and the CSS fails. Here is the view of what happens.

    Ants.PNG

    Notice that the spacing above the word "Ants" is missing. Firebug isn't help because the span is just an element.style.

    Here is the WP version
    http://www.layneheiny.com/2012/11/11/how-do-you-handle-cold-weather/

    Here is the XF version
    http://www.layneheiny.com/community/threads/how-do-you-handle-cold-weather.516675/

    Any suggestions on what to put in the XF css style to get the spacing?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It's using inline styling. There is no class to select on.

    Presumably the XenScripts addon has code for this replacement. Perhaps you could find that code and change the replacement?
     
    LPH likes this.
  3. LPH

    LPH Well-Known Member

    Code:
            $body = '';
            if($post_contains == 'full')
            {
                $body = '[quote]' . XenForo_Helper_String::autoLinkBbCode(XenForo_Html_Renderer_BbCode::renderFromHtml(nl2br($content))) . "[/quote]";
            }
    
    If the quote was removed then would the posting keep all the tags?
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I don't see how that would affect it. But I don't use XenScripts.
     

Share This Page