1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Guest access question.

Discussion in 'XenForo Questions and Support' started by WCFA, Feb 20, 2014.

  1. WCFA

    WCFA Active Member

    New to the forum switched from SMF, on my old forum guess could only see certain threads I guess you call them nodes here. That was to give intro and joining info etc.
    Because we close off the rest of the forum to members only so is why only certian areas can have guest access.

    I digress, I am trying to setup XF so a visiting guest not logged in will see two guess boards ( nodes ) only.
    I tried limiting the guest to view and then went to permissions and allowed those board.
    But still does not show for guest.

    I am doing something wrong I am sure.

    Thanks
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. WCFA

    WCFA Active Member

    I read those above seems that what I am doing yet the board still can not be seen by guest .
    However the boards is allowing guests? according to the allow setting however it does not show.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    What is the URL to your site?

    If you have set the main "view" permission to not set, then guests won't be able to see anything.
     
  5. WCFA

    WCFA Active Member

    Its westcoastfirearms.org
    Sorry very new to this software.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    it just looks like the node permissions are wrong.
    Try using the Permissions Analyzer.
     
  7. WCFA

    WCFA Active Member

    I used it but wont accept guest as a user ?
     
  8. Liam W

    Liam W Well-Known Member

    I don't think there is a way to test for Guests...
     
  9. WCFA

    WCFA Active Member

    Doesn't return anything
     
  10. WCFA

    WCFA Active Member

    I hate being a newb at stuff, I knew SMf well and now it shard to figure out stuff
     
  11. WCFA

    WCFA Active Member

    Has to be something really simple LOL No other ideas ?
     
  12. Liam W

    Liam W Well-Known Member

    What do your permissions look like?

    In the Unregistered usergroup, set View Nodes to Not Set.

    Then in the two guest nodes, set the Unregistered Group 'View Node' to Allow.

    That should do the trick (don't use 'Never').

    Liam
     
  13. WCFA

    WCFA Active Member

    Hmmm and thats the settings I have o_O not sure why it wont show .
     
  14. WCFA

    WCFA Active Member

    Checked twice thats the setting yet main page by guest does not show it.
     
  15. Liam W

    Liam W Well-Known Member

    You haven't set the permissions right then. Are you sure unregistered is set to not set in the main permissions, and then allow in the node permissions?
     
  16. WCFA

    WCFA Active Member

  17. WCFA

    WCFA Active Member

    Group Permission shows allow for guest view .
    View Node allow. View

    Is there another setting I am missing ?
     
  18. Liam W

    Liam W Well-Known Member

    If the Unregistered group is set to allow for view nodes, then how are you removing their ability to view them? Are you revoking the permission elsewhere?

    Liam
     
  19. WCFA

    WCFA Active Member

    So no settings should allow view for guess and then give that one permission ?
    I am new less then 24 on the software have not set anything just came here and asked how to do that :)
     
  20. WCFA

    WCFA Active Member

    If I remove all views they get a login page,
     

Share This Page