• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Git this error when changing php from 5.6 into 5.5 or 7.0

#1
Code:
An exception occurred: Cannot send headers; headers already sent in /home/androi18/public_html/index.php, line 1 in /home/androi18/public_html/library/Zend/Controller/Response/Abstract.php on line 321
Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/Abstract.php at line 63
XenForo_ViewRenderer_Abstract->__construct() in XenForo/ViewRenderer/HtmlPublic.php at line 18
XenForo_ViewRenderer_HtmlPublic->__construct() in XenForo/Dependencies/Public.php at line 207
XenForo_Dependencies_Public->getViewRenderer() in XenForo/FrontController.php at line 568
XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 141
XenForo_FrontController->run() in /home/androi18/public_html/index.php at line 14
 

Slavik

XenForo moderator
Staff member
#2
This usually occurs if there has been some whitespace added at the start or end of the XenForo files, normally caused by a bad FTP transfer.

Can you re-upload the package files and use binary transfer in your FTP client and see if the error still occurs.
 
#3
This usually occurs if there has been some whitespace added at the start or end of the XenForo files, normally caused by a bad FTP transfer.

Can you re-upload the package files and use binary transfer in your FTP client and see if the error still occurs.
it mean i have to reinstall ? because if i use php 5.6 it's okay but if i use php 5.5 or 7.0 it got the error
 

Slavik

XenForo moderator
Staff member
#4
it mean i have to reinstall ? because if i use php 5.6 it's okay but if i use php 5.5 or 7.0 it got the error
No, you wouldn't need to re-install, simply re-upload the files from the upgrade package to ensure they are correct. You can also run the file health check to look for specific files which may be wrong.

Changing php versions may enable or suppress various errors/warnings or change a config setting you had for 5.6 which was allowing the files to run correctly.