1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Warning: File upload error - unable to create a temporary file

Discussion in 'Troubleshooting and Problems' started by suppy, May 11, 2015.

  1. suppy

    suppy Member

    Hey guys, got a little problem hope you can help.

    I've got a problem with installing a xenforo theme.

    Starting from a Fresh install. I installed Forum software called XenForo.
    This was done successfully so the next stage was to install the skin (xenfracture_light_1.4.3) for the forum.

    After Uploading the proper folders to the server I then atempted to install the skin framework file.

    To do this you I Logged into the Admin Panel on the forum and navigated to the Appearance tab.
    Next I clicked on the Import a Style link then navigate to the STYLE_XML/INSTALL_FIRST folder: This contains the core XenoMorph framework that all the skins will run off of.
    Once I selected the file I clicked on the import button (once you do that you will see the software rebuilding the templates and cache in the Admin panel /let it finish)

    As soon as I attempt it I got this error.

    Warning: File upload error - unable to create a temporary file in Unknown on line 0
    An exception occurred: Cannot send headers; headers already sent in , line 0 in /home/teamretr/public_html/library/Zend/Controller/Response/Abstract.php on line 321

    Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
    Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/Abstract.php at line 63
    XenForo_ViewRenderer_Abstract->__construct() in XenForo/ViewRenderer/HtmlAdmin.php at line 16
    XenForo_ViewRenderer_HtmlAdmin->__construct() in XenForo/Dependencies/Admin.php at line 122
    XenForo_Dependencies_Admin->getViewRenderer() in XenForo/FrontController.php at line 537
    XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 141
    XenForo_FrontController->run() in /home/teamretr/public_html/admin.php at line 13


    I would like to add I have installed this many time before and never had this problem.


    The second problem which I think is connected is I can't upload upload files on forum threads.
    When writing a thread if I click the (upload a file tab) be it a image/file whatever nothing happens but if I look at the server error logs I get this message.

    Error Info
    Zend_Controller_Response_Exception: Cannot send headers; headers already sent in , line 0 - library/Zend/Controller/Response/Abstract.php:321
    Generated By: supremo, A moment ago
    Stack Trace
    #0 /home/teamretr/public_html/library/Zend/Controller/Response/Abstract.php(115): Zend_Controller_Response_Abstract->canSendHeaders(true)
    #1 /home/teamretr/public_html/library/XenForo/ViewRenderer/Abstract.php(63): Zend_Controller_Response_Abstract->setHeader('X-Frame-Options', 'SAMEORIGIN')
    #2 /home/teamretr/public_html/library/XenForo/ViewRenderer/Json.php(17): XenForo_ViewRenderer_Abstract->__construct(Object(XenForo_Dependencies_Public), Object(Zend_Controller_Response_Http), Object(Zend_Controller_Request_Http))
    #3 /home/teamretr/public_html/library/XenForo/Dependencies/Abstract.php(124): XenForo_ViewRenderer_Json->__construct(Object(XenForo_Dependencies_Public), Object(Zend_Controller_Response_Http), Object(Zend_Controller_Request_Http))
    #4 /home/teamretr/public_html/library/XenForo/Dependencies/Public.php(209): XenForo_Dependencies_Abstract->getViewRenderer(Object(Zend_Controller_Response_Http), 'json', Object(Zend_Controller_Request_Http))
    #5 /home/teamretr/public_html/library/XenForo/FrontController.php(537): XenForo_Dependencies_Public->getViewRenderer(Object(Zend_Controller_Response_Http), 'json', Object(Zend_Controller_Request_Http))
    #6 /home/teamretr/public_html/library/XenForo/FrontController.php(141): XenForo_FrontController->_getViewRenderer('json')
    #7 /home/teamretr/public_html/index.php(13): XenForo_FrontController->run()
    #8 {main}
    Request State
    array(3) {
    ["url"] => string(114) "http://team-retro.com/index.php?att...c94a7bc2e20ebe79b682decccc6&content_type=post"
    ["_GET"] => array(3) {
    ["attachments/do-upload_json"] => string(0) ""
    ["hash"] => string(32) "8e2ffc94a7bc2e20ebe79b682decccc6"
    ["content_type"] => string(4) "post"
    }
    ["_POST"] => array(7) {
    ["Filename"] => string(9) "slide.jpg"
    ["_xfToken"] => string(8) "********"
    ["content_data"] => array(1) {
    ["thread_id"] => string(1) "1"
    }
    ["_xfResponseType"] => string(4) "json"
    ["_xfSessionId"] => string(32) "7c2e06dcdef1b1b484ec0a5995815d48"
    ["_xfNoRedirect"] => string(1) "1"
    ["Upload"] => string(12) "Submit Query"
    }
    }
     
    Last edited: May 11, 2015
  2. suppy

    suppy Member

    There is also a third problem..
    Over the last year or so I also used a article system with a widget framework (portal) with this you can more easily promote valued content on your forums, as well as manage fully modular widgets around your website.
    When you promote content from forum to homepage you have to upload a image into a into a feature slider. you do this by uploading your image on the forum but this no longer works. It's worked for years but since my website went down this has not worked. I can no longer upload from website.

    This is the main reason I'm doing a full rebuild as I couldnt get this to work anymore.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    The 'headers already sent' message is typically due to white space in a php file.
    Have you edited any of the php files?

    Try downloading a fresh copy of the upgrade .zip from your customer area and extracting and uploading this file: library/Zend/Controller/Response/Abstract.php

    Any specific issues related to add-ons or styles will need to be addressed to the authors.
     
  4. suppy

    suppy Member

    Yeap! tried uploading new file: library/Zend/Controller/Response/Abstract.php still not working..
    Still can't upload upload files on forum threads.
    I've not been able to get as far as installing the style as I cant upload from admin.


    I'm going to do a new fresh install..
     
  5. Brogan

    Brogan XenForo Moderator Staff Member

    If you are transferring the files via FTP, I recommend using WinSCP (don't use Filezilla).
     
    maszd likes this.
  6. Mike

    Mike XenForo Developer Staff Member

    This is really the initial error. The latter error happens because of this.

    This is indicative of a PHP misconfiguration or a server error. If this is a shared server (or possibly a managed server), you should contact your host for them to resolve it. Otherwise, you should be looking at any issues in your server's temp directory (/tmp) or the upload_tmp_dir php.ini configuration value.
     
  7. suppy

    suppy Member

    Just tried again... Same problem. :(

    Host is going to reset the hosting space.

    Thanks for help
     
    Last edited: May 11, 2015

Share This Page