• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 Gifs Using ImageMagick

#1
Hello,
I was wanting to make Gif images able to load as profile avatars, and found out the way to do this was to use the ImageMagick extension for php.
I went to my cPanel, and checked for php to use the imagick extension, and then went on the ACP, and set the forums to use ImageMagick, however my forums still do not have gifs working as avatars across the forums. I checked if this was an issue with my forum style, however, it does not work on the default style. Is imagick not the same thing as ImageMagick?
Does anyone know what I could be doing wrong?
 

Brogan

XenForo moderator
Staff member
#2
Has the imagick PHP PECL extension been installed and compiled against the ImageMagick libraries on the server?
Both need to be installed.

Did you restart Apache after installing?
 
#3
Has the imagick PHP PECL extension been installed and compiled against the ImageMagick libraries on the server?
Both need to be installed.

Did you restart Apache after installing?
This is on shared hosting, so I will contact the support team with that. Thanks for the quick reply!
 
#4
Has the imagick PHP PECL extension been installed and compiled against the ImageMagick libraries on the server?
Both need to be installed.

Did you restart Apache after installing?
The company replied the following:
Please be informed that imagick PHP PECL extension has already installed on our server. Can you please contact Xenforo support and ask what all PHP extensions are required to make gif avatars to work on your forum? I have checked Xenforo forums regarding this and found that we have to disable GD in order to make it work. Please confirm this with them and let me know.
 

rafass

Well-known member
#5
This is what you have to do:
Ok I finally solved this annoying issue. Since I'm using cPanel/WHM on CentOS 6.4, this is what I did:
  1. Remove existing ImageMagick packages.
    yum remove ImageMagick
  2. Remove existing PECL imagick package.
    pecl uninstall imagick
  3. Download latest ImageMagick source. Latest is ImageMagick 6.8.6-9 at the time of posting.
    wget http://www.imagemagick.org/download/ImageMagick.tar.gz
  4. Extract tarball.
    tar zxvf ImageMagick.tar.gz
  5. Compile and install.
    cd ImageMagick-6.8.6-9
    ./configure --prefix=/usr && make && make install
  6. Configure the dynamic linker run-time bindings
    ldconfig /usr/bin
  7. Install latest version of PECL imagick package. Latest is imagick 3.1.0 (RC3) at the time of posting.
    pear config-set preferred_state beta
    pecl install imagick
    pear config-set preferred_state stable
Now check if imagick loaded correctly in php --info. Then try uploading an animated image and you should no longer get that error.
And everything will work absolutely perfect.
 

Mike

XenForo developer
Staff member
#7
If you were able to select ImageMagick in the XF ACP, that's really all you can do. I would note that if you're talking about animated GIF support, you need to reupload any avatars that should be animated for it to work.

If it doesn't work, that would seem to imply an issue internal to ImageMagick, not something that XF really has any control over unfortunately. (It may be related to the version of the imagick PECL extension or the version of ImageMagick it's compiled against. The instructions above essentially have you recompiling each to ensure they're the latest versions.)