Game Servers [Deleted]

ceribik

Well-known member
Does this add-on support Unturned and Ark?
From my quick research, they both use the source query protocol and so you ought to be able to use the "source" server type. You just have to make sure you use the correct query port (which can be different from the default game port).

By default, the query port for unturned is 27016, and for Ark, it is 27015.
 
I've added a TS3 server, an ARK server and a Minecraft server. All of the Player counts (which are not 0) continue to list as such. I've also verified that the TS3 server is set properly with guest permissions (and have it added to gametracker/tsviewer, etc).

Any help to determine what the issue is would be greatly appreciated.
 
Can you send me a screenshot of the server edit page for your TS3 server, and if you open up library/GameServers/GameQ/gameq/protocols/teamspeak3.php, can you copy what the following line says:
Code:
protected $master_server_port =
And by "doesn't work" you mean the player and max players count stays at 0?
Sorry for not being descriptive with the error (I personally hate that). Yes, the counts are staying at 0.


Code:
protected $master_server_port = 10011;
 

ceribik

Well-known member
I've added a TS3 server, an ARK server and a Minecraft server. All of the Player counts (which are not 0) continue to list as such. I've also verified that the TS3 server is set properly with guest permissions (and have it added to gametracker/tsviewer, etc).

Any help to determine what the issue is would be greatly appreciated.
I just tested your server with the same settings and it is showing as 11/400 for me.

Are there any errors in the XenForo server log, or the PHP error log?

Can you also PM/message me the PayPal name and email you used to purchase the addon?
 

ceribik

Well-known member
How do i know that o,o idk how i set it to be on sidebar
You have to decide which of the four available methods to use. Read step 4 of the instructions:

  1. Upload the contents of the upload folder
  2. Install using the included XML file
  3. Add your servers: Admin panel -> Applications -> Game Servers -> List Servers -> Add server
  4. Setup one or more output methods:
Widget Framework
Use the "Game Servers" renderer

XenPorta
Upload the contents of the "xenporta/upload" folder, and install the XML file in the "xenporta" folder as a XenPorta block.

XenPorta 2
Install the XML file in the "xenporta2" folder as a XenPorta 2 widget, and add the widget to a layout as desired.

Template
Include the "gameservers_template" template.
I have highlighted step 4 for your convenience...
 

ceribik

Well-known member
And how do i set it up.....
You said in your "review" that you use XenPorta. Upload the corresponding files as mentioned in the instructions, and add the GameServers block like any other block.

XenPorta
Upload the contents of the "xenporta/upload" folder, and install the XML file in the "xenporta" folder as a XenPorta block.

OR

XenPorta 2
Install the XML file in the "xenporta2" folder as a XenPorta 2 widget, and add the widget to a layout as desired.
 
You said in your "review" that you use XenPorta. Upload the corresponding files as mentioned in the instructions, and add the GameServers block like any other block.

XenPorta
Upload the contents of the "xenporta/upload" folder, and install the XML file in the "xenporta" folder as a XenPorta block.

OR

XenPorta 2
Install the XML file in the "xenporta2" folder as a XenPorta 2 widget, and add the widget to a layout as desired.
i did but the portal only shows 1 thing and thats the articles itself no sidebars or anything :(
 

ceribik

Well-known member
i did but the portal only shows 1 thing and thats the articles itself no sidebars or anything :(
Did you add the GameServers block to your current layout in XenPorta? Are you sure you are looking at the right XenPorta page, and not just the forums (where XenPorta isn't active by default)?

Also, have you enabled at least one server in the Game Servers options?
 
Did you add the GameServers block to your current layout in XenPorta? Are you sure you are looking at the right XenPorta page, and not just the forums (where XenPorta isn't active by default)?

Also, have you enabled at least one server in the Game Servers options?
i have maybe you can help me, the xenporta only shows posts from my announcements but nothing else like sideblocks etc
 

ceribik

Well-known member
i have maybe you can help me, the xenporta only shows posts from my announcements but nothing else like sideblocks etc
It's not really within the scope of my support. However, if you PM me some admin credentials I can try to help show the addon on a sideblock. Failing that, you will have to ask the developers of XenPorta for support.
 
Top