1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Friendly URLs

Discussion in 'XenForo Questions and Support' started by jleeevinnn, Jun 21, 2014.

  1. jleeevinnn

    jleeevinnn Member

    Hello, I recently transfered from a shared host to a VPS, copied all file and exported and imported my .sql database. I have everything set up, .htaccess file in root, it's contents:
    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    Then, I have Friendly URLs enabled, mod_rewrite enabled on my vps. And still, when I try to perform actions like logout, login, account, etc I get this:
  2. AndyB

    AndyB Well-Known Member

    If memory serves, the following needs to have the # symbol removed:

    RewriteBase /xenforo

    if that doesn't work, try this:

    RewriteBase /
  3. jleeevinnn

    jleeevinnn Member

    Neither work :(
  4. AndyB

    AndyB Well-Known Member

    Is the path to your Xenforo installation in the web root?
    jleeevinnn likes this.
  5. jleeevinnn

    jleeevinnn Member

    That fixed it! Thanks!
  6. jleeevinnn

    jleeevinnn Member

    Oh no! I was messing with my Email Options trying to set up my google SMTP mail system and randomly on reload the friendly URLs are back to not working!

    I have RewriteBase /
    and my Board URL is set to the root directory of all my xenforo files.
  7. AndyB

    AndyB Well-Known Member

    You might ask your web hosing company for help on this, they are often very quick to resolve issues like this.
  8. jleeevinnn

    jleeevinnn Member

    I don't have a "web" host, this is a VPS rented off OVH.com
  9. Mike

    Mike XenForo Developer Staff Member

    Out of the box Apache settings don't allow .htaccess files as they have "AllowOverride" set to None in the httpd.conf. You would need to change/check that.

    Otherwise if they worked before, nothing that can be set in XenForo can change that. Something must have changed elsewhere.

Share This Page