1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Friendly URLS

Discussion in 'XenForo Questions and Support' started by CLMontague, Apr 4, 2014.

  1. CLMontague

    CLMontague New Member

    Hello,

    this is most likely a bit of configuration that I am missing, but when I enable Friendly URLS I get the error 'Not found' on my forum, I have checked if the module is loaded and it appears to be, bellow is my .httaccess file

    '
    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off
    #</IfModule>

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>

    thank you!
     

    Attached Files:

  2. Mike

    Mike XenForo Developer Staff Member

    If you're sure the .htaccess is in place correctly, then:
    1. mod_rewrite may be missing from Apache (likely not the case here)
    2. AllowOverride may not be specified at the VHost/httpd.conf level (probably the case).
    3. You may need to uncomment and use the RewriteBase line.
     
  3. CLMontague

    CLMontague New Member

    Thank you very much.

    I changed 'AllowOverride none' to 'AllowOverride All' and uncommented 'RewriteBase line' now all is fine thank you!
     

Share This Page