• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Friendly URL's

Ablac

Active member
#1
Ive tried everything and i cant get Friendly URL's to work...

I have renamed my htaccess.txt to .htaccess.txt and enabled Friendly URL's and i get 404 errors when trying to browse websites.

I have tried changing the rewrite rules and that dosnt work either.

my .htaccess.txt file is located in public_html

And i will check this post, and i do have Team Viewer installed if anyone would be willing to help fix the issue manually :) Thx again!
 

island

Active member
#2
II have renamed my htaccess.txt to .htaccess.txt and enabled Friendly URL's and i get 404 errors when trying to browse websites.
Did you rename it to simply .htaccess (no .txt should be there - only .htaccess for the .htaccess file to be read by the webserver and function)
 
F

Floris

Guest
#4
The reason it's htaccess.txt first, is so you upload it not in binary mode, and it will be visible in your directory. Plus, this way it's easier to edit for most users.
Once on the server the web server expected ".htaccess"
The . = hidden file.
And the .txt isn't needed. The web server knows what to do with the plain text file.
I hope this help explain that a little.
 

Ablac

Active member
#5
I understood the . just didnt realize that i was needed to remove the .txt :) Glad thats working now ive been trying to get it to work since i got Xenforo lolz