XF 1.2 Friendly urls Turkish Problem

Hi,
vBulletin to xenforo will pass. But the Turkish character has problems.

Example:
Gündüz Kılıç Şanlı (FORUMS)
http://www.sitename.com/forums/guenduez-klc-sanl-galatasaray-tarihi-forumu.21/

Galatasaray'ın 1959'dan 2010'a Kadar Tüm Kadroları (Posts)
http://www.sitename.com/threads/galatasarayn-1959dan-2010a-kadar-tuem-kadrolar.35851/

ÖÇŞIİÜĞ letters the problem..


-- vBulletin to Xenforo I'd appreciate if the information about the transition.

My English is not very good.. :( I hope you can understand me.

Best regards,
M. Yavuz
 

Mike

XenForo developer
Staff member
I'm not sure what the report is exactly. You can disable the "romanize" option if you don't want that conversion to happen. Romanization is generally language unaware so it's possible that a particular character may be romanized different in your language than others.
 
I'm not sure what the report is exactly. You can disable the "romanize" option if you don't want that conversion to happen. Romanization is generally language unaware so it's possible that a particular character may be romanized different in your language than others.
Romanize disabled. Took care of this problem as follows.
Link.php
Find :
PHP:
        $title = strtr(
            $title,
            '`!"$%^&*()-+={}[]<>;:mad:#~,./?|' . "\r\n\t\\",
            '                            ' . '    '
        );
Add after
PHP:
$title = strtr($title, array(
        '"' => '',
        "'" => '',
        "Ö" => "o",
        "ö" => "o",
        "C" => "c",
        "c" => "c",
        "Ğ" => "g",
        "ğ" => "g",
        "Ş" => "s",
        "ş" => "s",
        "Ü" => "u",
        "ü" => "u",
        "İ" => "i",
        "ı" => "i",
        "Ç" => "c",
        "ç" => "c",
        "é" => "i",
        "â" => "a",
        "Ê" => "e",
        "Â" => "a",
        "?" => "_",
        "*" => "_",
        "." => "_",
        "," => "_",
        ";" => "_",
        ")" => "_",
        "(" => "_",
        "{" => "_",
        "}" => "_",
        "[" => "_",
        "]" => "_",
        "!" => "_",
        "+" => "_",
        "%" => "_",
        "&" => "_",
        "#" => "_",
        "$" => "_",
        "=" => "_",
        "ê" => "e",
        "." => "-"
        ));
Sample File Attached Files ;)
 

Attachments

Last edited:

aliunal

Member
Romanize disabled. Took care of this problem as follows.
Link.php
Find :
PHP:
        $title = strtr(
            $title,
            '`!"$%^&*()-+={}[]<>;:mad:#~,./?|' . "\r\n\t\\",
            '                            ' . '    '
        );
Add after
PHP:
$title = strtr($title, array(
        '"' => '',
        "'" => '',
        "Ö" => "o",
        "ö" => "o",
        "C" => "c",
        "c" => "c",
        "Ğ" => "g",
        "ğ" => "g",
        "Ş" => "s",
        "ş" => "s",
        "Ü" => "u",
        "ü" => "u",
        "İ" => "i",
        "ı" => "i",
        "Ç" => "c",
        "ç" => "c",
        "é" => "i",
        "â" => "a",
        "Ê" => "e",
        "Â" => "a",
        "?" => "_",
        "*" => "_",
        "." => "_",
        "," => "_",
        ";" => "_",
        ")" => "_",
        "(" => "_",
        "{" => "_",
        "}" => "_",
        "[" => "_",
        "]" => "_",
        "!" => "_",
        "+" => "_",
        "%" => "_",
        "&" => "_",
        "#" => "_",
        "$" => "_",
        "=" => "_",
        "ê" => "e",
        "." => "-"
        ));
Sample File Attached Files ;)
Thank you
 
Top