1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Friendly URL's - Not Found

Discussion in 'Troubleshooting and Problems' started by MasterBugPatch, Dec 7, 2014.

  1. MasterBugPatch

    MasterBugPatch New Member

    For the last 30 minutes I've been looking at other post trying to correct my Friendly URL's. Nothing is working, maybe it's because of all the special things I have.

    Here is my details:
    • I'm using Xenporta
    • Index Page Route set to "portal/" in Basic Board Information
    • My host does have the write-read- thing on.
    My .htaccess file looks like this:
    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you
    #    cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    #    SecFilterEngine Off
    #    SecFilterScanPOST Off
    #</IfModule>
    
    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 500 default
    
    <IfModule mod_rewrite.c>
        RewriteEngine On
    
        #    If you are having problems with the rewrite rules, remove the "#" from the
        #    line that begins "RewriteBase" below. You will also have to change the path
        #    of the rewrite to reflect the path to your XenForo installation.
        RewriteBase /public
    
        #    This line may be needed to enable WebDAV editing with PHP as a CGI.
        #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    
        RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
            RewriteCond %{HTTPS} off
            RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
        RewriteRule ^.*$ - [NC,L]
        RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
        RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
    I'm running Apache with CPanel. Any idea as to why this isn't working?
    The website is https://masterbugpatch.com/
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Start with the default .htaccess file from the XF zip file.

    Your RewriteBase appears wrong, and the https rule placement is wrong. Start with the default file to make sure that works.
     
  3. MasterBugPatch

    MasterBugPatch New Member

    Not able to use that, I'm using code in my .hataccess for my HTTPS also.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Well, this alone will break friendly URLs:

    Code:
    RewriteCond %{REQUEST_FILENAME} -f [OR]
        RewriteCond %{REQUEST_FILENAME} -l [OR]
        RewriteCond %{REQUEST_FILENAME} -d
            RewriteCond %{HTTPS} off
            RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
        RewriteRule ^.*$ - [NC,L]
    
    You have inserted a custom rewrite rule between the "do nothing" rule and its conditions. The result will be that ALL friendly URLs do nothing because they all hit that "do nothing" rule because it has no conditions anymore because your custom rule hijacked those conditions.
     

Share This Page