1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Friendly URLs... broke.

Discussion in 'Troubleshooting and Problems' started by mauzao9, Feb 12, 2015.

  1. mauzao9

    mauzao9 Well-Known Member

    Hello there.

    I had yesterday moved my installation to a new machine, i installed all requirements, imported databases, everything perfect. Expect one thing.

    Even with mod_rewrite installed and loaded, and the old .htaccess file that worked correctly on the other server, now i can't get it to work no matter what i do.

    I had tried to uncomment RewriteBase, etc... What may be wrong?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It is an Apache web server?

    Have you confirmed this with your host?
  3. mauzao9

    mauzao9 Well-Known Member

    Yes, phpinfo shows mod_rewrite enabled, as does on terminal. When i enable friendly it hides the /index.php at home, but everything else is a 404 error.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Are you sure the .htaccess file was copied across?

    It is a hidden file so may not have done so.

    Have you also confirmed with your host that they allow overrides via an .htaccess file?
  5. mauzao9

    mauzao9 Well-Known Member

    -- Edit: --
    Oups i missed something, the default apache,
    <Directory /var/www>
    Options FollowSymLinks
    AllowOverride None

    None to All fixed it.
    Last edited: Feb 12, 2015
  6. iZeroLogic

    iZeroLogic Member

    Where would I reconfigure the AllowOverride syntax. I can't seem to figure where to find it.
  7. Mike

    Mike XenForo Developer Staff Member

    Either in httpd.conf or your VHost configuration.
  8. iZeroLogic

    iZeroLogic Member

    I'm still having trouble with the friendly URL's. Still Receing 404 Error Page.

    The website is Apache
    mod_rewrite is enabled
    RewriteBase is uncommented and directed to the forum directory in the .htaccess file.
    As well as the Allowoverride set to All.
    Last edited: Mar 14, 2015

Share This Page