1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Friendly URL not working?

Discussion in 'Troubleshooting and Problems' started by Flying Anonymoose, Jun 15, 2015.

  1. Flying Anonymoose

    Flying Anonymoose New Member

    I can't seem to get the friendly URL to work. Once I enable it the index.php is no longer added to the home page URL but I get an error 404 page when I click on anything else.
  2. Slavik

    Slavik XenForo Moderator Staff Member

    Is the relevant .htaccess in place?
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    It's very likely .htaccess as Slavik suggested, but here is a list of all usual suspects:

    1) The .htaccess file is not in place in your forum directory.

    2) Sometimes you need to specify RewriteBase in your .htaccess file (specify the name of your forum directory):

    RewriteBase /xenforo

    3) Your server doesn't have mod_rewrite installed. Consult with your host about this.

    4) Your server doesn't have AllowOverride enabled:


    Consult with your host about this.
  4. Flying Anonymoose

    Flying Anonymoose New Member

    The .htaccess is there, I've tried uncommenting it and changing the location to '/', '/var/forums', and '/forums' but without any success. I just installed mod_rewrite on the server before this, so it's not a lack of that.
  5. Mike

    Mike XenForo Developer Staff Member

    If you're mentioning installing mod_rewrite, it's likely the AllowOverride issue. It's off by default.
  6. Flying Anonymoose

    Flying Anonymoose New Member

    I tried enabling it (I'm running Debian, and I've been told I need to edit the file located at /etc/apache2/sites-available/default. Here's the a snippet I grabbed of my quick edit that should have allowed it

    It appears to work on the home page, but as soon as I click on any forum links this pops up

    Quick edit: I've also tried to find the error log file, which I've used before, but I can't remember where it is.
  7. Flying Anonymoose

    Flying Anonymoose New Member

    Got it to work! Not sure really what was the problem. All I did was change the RewriteBase (which was already at '/') to '/var/forums' and then back again. Maybe it just took a while for the AllowOverride to update?

Share This Page