1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Forums as subdomain using XenPorta

Discussion in 'XenForo Questions and Support' started by Sour, Mar 19, 2013.

  1. Sour

    Sour Member

    My goal is to have my forums(currently domain.com/forum) to be forums.domain.com and have XenPorta be ighub.net(which it is currently.) I would then like the forum button in the navigation bar to redirect to forums.domain.com aswell.

    Sites that do this:
    digitalpoint.com - Not XenPorta, but similar

    I have found other threads where people were asking the same thing, but I haven't seen a direct answer yet.

    Oh, and my host is HawkHost if that helps. I don't know exactly how to set up my subdomain. Do I set it's root to the root folder and then redirect it to domain.com/forums?

    Any help is greatly appreciated, thanks!
  2. Sour

    Sour Member

    Did I explain what I'm trying to do well enough, or do people just not know how? If you don't understand what I'm asking, just tell me. I will gladly elaborate on what I'm trying to accomplish.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You will need to change your cookie domain to work on all subdomains:


    Then your host needs to park the additional subdomain on your existing site such that it can be accessed from either URL. Then you will need to edit various links throughout the templates to use the subdomain when appropriate. Some custom rewrite rules in your .htaccess file can also be used to enforce specific subdomains given certain conditions. Example in #2 of this post:


    I personally wouldn't bother though. It's a lot of trouble for something that isn't functional... unless you have some functional reason for wanting different subdomains.
  4. Sour

    Sour Member

    Ok, thanks. I'll probably end up just keeping the forums the way they are. Seems like a lot of hassle for something just for looks.

Share This Page