1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Forum URL path incorrect after backup and restore

Discussion in 'Troubleshooting and Problems' started by Paul, Mar 8, 2011.

  1. Paul

    Paul Well-Known Member


    Some strange issues here -

    Have successfully backed up and restored, and i can launch the main forum page.

    however i get the following whenever i try to access one of the forums...

    Any advice greatfully received

  2. Ryan Kent

    Ryan Kent Well-Known Member

    Try removing one of the /forums from your URL
  3. Vincent

    Vincent Well-Known Member

    Go to Options -> Basic Board Information -> Board URL.

    Is in that link a "/forums" part?
  4. Mike

    Mike XenForo Developer Staff Member

    Rename htaccess.txt to .htaccess
  5. Paul

    Paul Well-Known Member

    Thanks Mike - that enabled me to get into the ACP, so thats good :)

    It;s forum friendly url linked - if i disable forum friendly urls, access works, as soon as i switch back on again i get the above issues again.

    Any ideas as to how to fix this issue, and re-enable friendly Urls again?

  6. jondoe0069

    jondoe0069 Member

    "If you enable this option, the links generated by the system will not include "index.php?". However, to enable this, mod_rewrite must be available and an appropriate .htaccess file must be in place."

    Do we need custom .htaccess? For which directories to make this work? Is there an example?

  7. Brogan

    Brogan XenForo Moderator Staff Member

    The .htaccess file is included with the package.
    If you are on an Apache server and mod-rewrite is installed, then all you need to do is enable friendly URLs.

    This may provide more information: http://xenforo.com/help/friendly-urls/
  8. jondoe0069

    jondoe0069 Member

    Okay. I'm sure it's not installed since I'm on an unmanaged VPS. I will install and retry.

    Thanks for your quick reply. I'm sure the Paul's issue is similar since my symptoms were exactly the same.
  9. Mike

    Mike XenForo Developer Staff Member

    If this is the same server and it did work before, then I have to assume the .htaccess file wasn't created correctly.

    If it's a different server, then you'll have to contact your host (see the Apache section here: http://xenforo.com/help/friendly-urls/).
  10. Paul

    Paul Well-Known Member

    Ok. Have checked and i have have mod_rewrite installed..... and have restarted httpd as a precaution, however same still happens - if i turn friendly urls on it fails...

    http://www.pinballinfo.co.uk/phpinfo.php - shows this module loaded...

    It's a new server (unmanaged VPS) so one of those things i'm gonna have to fathom out myself unfortunately :(

    Thanks again
  11. Mike

    Mike XenForo Developer Staff Member

    Brogan likes this.
  12. Paul

    Paul Well-Known Member

    Mike - you got it in one - AllowOverride was set to None - set to all, restarted Httpd, and bingo - all now working

    Many thanks for everyone's help on this one :)

  13. jondoe0069

    jondoe0069 Member

    This was my issue as well. AllowOverride set to All and everything works now! Sweet, thanks!

Share This Page