• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Forum just started failing

#1
Hi

Forum was working fine and has just started to break ....

Loads of errors on the error log like

Code:
Mysqli prepare error: Unknown column 'thread.username' in 'field list'
Code:
library/Zend/Db/Statement/Mysqli.php:77
All in the same library

I can still access the admin

From the forum if you try and do anything you get the following

Screen shot 2011-07-09 at 23.34.59.png
 

Brogan

XenForo moderator
Staff member
#3
Everything I've read on this seems to indicate the problem is with using incorrect single quotes in a query, assuming of course thread.username and thread.thread_id still exist (they're both fields in the thread table).

Did you do anything/make any changes prior to this error appearing?
Install any add-ons?
 

Brogan

XenForo moderator
Staff member
#6
As Jake has pointed out, it could be related to the chat add-on.
So try disabling that first.

Curiously though I've had that installed for months but have never had that error.
Do you use the archive feature?

A quick look shows that a thread ID and member ID are required for the archive.
Did you perhaps delete the thread and/or user?

Even so, try setting both to 0 to see if that resolves it.
 
#7
Chat has been in since day one

I haven't myself deleted a thread or user

Borbole is looking at it and says "I have missing fields at th ethread table"
 

Brogan

XenForo moderator
Staff member
#9
I did mention that above, but it would be highly unusual for some fields to suddenly disappear from the thread table.

You will need to restore from a recent backup if that's the case.
 
F

Floris

Guest
#12
Thanks for the help ..... I'm on to hostgator to see if they had a server issue ... but they aren't very forthcoming
For a host it is horrible to figure out on a per customer basis what was the previous state, the current one, what the software is, how it works, and what potentially the problem could be. That said: HostGator is usually not forthcoming when it comes to getting information about what's going on with the box your site resides on. Like many hosts they are the GoDaddy of hosting.

I recommend to report the issue to the author of the plugin you have installed, and run check/optimize on your database to find potential issues if it is hosting related. Temp fix: uninstall the chat plugin.