1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 editing a user takes me to 'create new user' instead.

Discussion in 'Troubleshooting and Problems' started by electrogypsy, Dec 6, 2013.

  1. electrogypsy

    electrogypsy Active Member

    i just noticed that all my newest registrations on my forum can't get their passwords sent to them, and when i go to take a look at their account in the admin cp, i get taken to a 'create new user' page instead of the usual 'edit user' page. the strange thing is that the 'create new user' page has all their info filled in (username, email, etc), but when i try to change anything i get several alerts like "username must be unique, this already exists" (same for email), and 'you must provide a password'. pretty much all the stuff you'd expect from a new user form, but not an edit user page.

    i've checked some of the older accounts and they work fine (i'm taken to the 'edit user' page).

    i have no idea if this is related, but i'm getting this error as of today:

    Code:
    Server Error Log
    Error Info
    Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: Unknown column 'xengallery' in 'field list' - library/Zend/Db/Statement/Mysqli.php:77
    Generated By: Unknown Account, 16 minutes ago
    Stack Trace
    
    #0 /srv/www/squattheplanet.com/public_html/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `xf...')
    #1 /srv/www/squattheplanet.com/public_html/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `xf...')
    #2 /srv/www/squattheplanet.com/public_html/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `xf...')
    #3 /srv/www/squattheplanet.com/public_html/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #4 /srv/www/squattheplanet.com/public_html/library/XenForo/DataWriter.php(1612): Zend_Db_Adapter_Abstract->insert('xf_user_option', Array)
    #5 /srv/www/squattheplanet.com/public_html/library/XenForo/DataWriter.php(1601): XenForo_DataWriter->_insert()
    #6 /srv/www/squattheplanet.com/public_html/library/XenForo/DataWriter.php(1393): XenForo_DataWriter->_save()
    #7 /srv/www/squattheplanet.com/public_html/library/XenForo/ControllerPublic/Register.php(294): XenForo_DataWriter->save()
    #8 /srv/www/squattheplanet.com/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_Register->actionRegister()
    #9 /srv/www/squattheplanet.com/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 /srv/www/squattheplanet.com/public_html/index.php(13): XenForo_FrontController->run()
    #11 {main}
    
    Request State
    
    array(3) {
      ["url"] => string(43) "http://squattheplanet.com/register/register"
      ["_GET"] => array(1) {
        ["/register/register"] => string(0) ""
      }
      ["_POST"] => array(12) {
        ["username"] => string(14) "elysianlottery"
        ["email"] => string(22) "mj.marlowe24@gmail.com"
        ["password"] => string(8) "********"
        ["password_confirm"] => string(8) "********"
        ["dob_month"] => string(1) "6"
        ["dob_day"] => string(2) "03"
        ["dob_year"] => string(4) "1991"
        ["gender"] => string(6) "female"
        ["timezone"] => string(16) "America/New_York"
        ["agree"] => string(1) "1"
        ["_xfToken"] => string(8) "********"
        ["reg_key"] => string(32) "59baac3767b1f5f308a0c91843e33584"
      }
    }
    but i haven't changed anything in relation to user accounts in quite some time. after going through all the most recent accounts, it looks like this started happening to people registering after november 10th (accounts before then take me to the proper 'edit user' page, not 'create new user'), so i have about 200+ accounts that are screwed up.

    also, i just discovered that when i search for one of these screwed up users on the front end of my forum, i get returned to the members list page with no error.

    sounds like maybe my user table got screwed up somehow? the only major event in the website during this time has been a server move to a vps (around november 20th or so).

    if someone could point me in the right direction to go from here, i'd sure appreciate it!
     
  2. electrogypsy

    electrogypsy Active Member

    oh, i forgot to mention that i get the error above when i tried creating a dummy test account. after clicking the submit button i got 'an unknown server error occured'... so i guess people aren't able to register for my forums now either.
     
  3. realaqu

    realaqu Active Member

    just a guess, log into your phpmyadmin, looking for table name "xf_user", change one of these screwed up user status to "valid", then do search and edit again
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    This is an issue with your gallery add-on. It looks like XenGallery.
     
  5. electrogypsy

    electrogypsy Active Member

    yeah, i'm going over it with the plugin author now. seems the 'xengallery' table wasn't created like it was supposed to be when the plugin was installed. i've added the table back, so hopefully people should be able to register for the site properly.

    unfortunately that didn't have any effect. the users are still messed up. i'm getting a few people emailing me now saying my forum told them their account was deleted when in fact they have not.

    im hoping the situation with people not being able to register is solved, but now i need to figure out how to fix all these screwed up accounts. anyone have any ideas?
     
  6. electrogypsy

    electrogypsy Active Member

    ok, now that the table is back in place people are able to register as normal. but i still have about 200 user accounts that are pretty screwed up, and i have no idea how to fix them. the problem as stated in the original post still stands.
     

Share This Page