1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Forum cannot connect outside

Discussion in 'Troubleshooting and Problems' started by Sparkiller, Oct 22, 2014.

  1. Sparkiller

    Sparkiller Member

    The last days i tried to use Facebook registration and User upgrades. Using all of these didn't work, because the forum software seems to be unable to connect to external services.

    The transaction log for the user upgrades just says "Connection to PayPal failed", with a similiar response from the integrated Facebook test: "Your server could not connect to Facebook (https://graph.facebook.com). Try again later. If the issue persists, contact your host."

    And i did contact my host, after already searching for answers here. I asked him about firewall settings and the server not being able to connect via SSL, according to this thread: https://xenforo.com/community/threads/yet-another-facebook-integration-problem.69530/). His response:

    The overall settings seem to be connect for the user upgrades (IPN activated at PayPal, etc.) and Facebook (App setup with correct domains and site url), so as a beginner in server matters i'm currently not sure what i can do next. Except asking here, of course... :D

    Thanks in advance for any help! I'll try to answer any necessary questions.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    If you have not made any changes to the forum software (upgrading, installing add-ons, etc.) and it was working previously, then it can only really be server related.
     
  3. Sparkiller

    Sparkiller Member

    Thanks, i also installed a fresh test version of XenForo and got the same error message from the Facebook test.

    One more question before i ask the server support again:
    If i open http://www.projektstarwars.de/payment_callback.php directly and already get "Connection to PayPal failed" as a response, this more or less confirms a configuration error?

    Edit: Setting up Twitter integration and then using the XenForo test results in "Error in HTTP request", if that is any help.
     
    Last edited: Oct 22, 2014
  4. Sparkiller

    Sparkiller Member

    Problem solved. The support told me to downgrade from PHP 5.6 to 5.5 and everything started to work fine.
     

Share This Page