• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 forcing ssl on all images on site

#1
Hello, I've recently switched from http to https and am having issues getting the full green lock. I know the issue is because of my website trying to load http images. I've read on here that you need to change your basic board information url and I've done that.

These are the errors i'm getting.
 

Mike

XenForo developer
Staff member
#5
Some of these are down to your image path-related style properties (specifying a full URL) or your smilie URLs (again, specifying a URL). You would need to adjust those.

If you're running 1.3 and the proxy option isn't showing, that would probably indicate that the upgrade hasn't run correctly. Check that you followed the instructions in the manual and re-perform them.
 
#6
Some of these are down to your image path-related style properties (specifying a full URL) or your smilie URLs (again, specifying a URL). You would need to adjust those.

If you're running 1.3 and the proxy option isn't showing, that would probably indicate that the upgrade hasn't run correctly. Check that you followed the instructions in the manual and re-perform them.
Ok i've re done upgrading to 1.3.5 and ticked 'Proxy Images' but however no images on my site are using the image proxy? Anything that could be causing this?
 

melbo

Well-known member
#7
You'll need to view your page source and start hunting down anything using http://
The image proxy only proxies images within posts. The rest of the images in your style will need to be rewritten as https://

Happy hunting.
 
#8
You'll need to view your page source and start hunting down anything using http://
The image proxy only proxies images within posts. The rest of the images in your style will need to be rewritten as https://

Happy hunting.
All fixed :) Took a while to hunt down most the images but it was worth searching, Got that green lock now :)