1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Forbidden Error - do not have permission to access /admin.php

Discussion in 'Troubleshooting and Problems' started by Zaeth, Nov 18, 2014.

  1. Zaeth

    Zaeth New Member

    Just put a fresh install of Xenforo 1.4.3 onto my shared hosting server with namecheap. The install went through fine without any issues. As soon as the install finished I went straight to editing templates. The first template I attempted to edit was DEFAULT but when I went to save it, I received an error.

    xerror.jpg

    Without any luck I went on to attempt to edit the Header template. The header template would save but the header.css would not. Resulting in the same error as shown above.

    Just wondering whats causing this issue and how I can go about fixing it as I really want to get editing!!
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    This is usually down to mod_security and something your host can help with if file permissions are correct.

    Edit - see you are in the ACP. Almost surely mod_security and something you'll need to contact the host about.
     
  3. Zaeth

    Zaeth New Member

    I have cPanel and access to FTP. I see in htaccess. that I can remove "#" from some lines of code to do with mod_security I think. Would that help?

    Anything I can do? Or just contact my host to check file permissions are correct.
     
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    You should contact your host, they should be able to determine what rules you are hitting and how to reconfigure your server.
     
  5. Zaeth

    Zaeth New Member

    Thanks for the fast replies! I contacted my host, showed them your reply to me and they hastily checked my issue. Not long afterwards they stated that:

    Host Support: "Our server's mod_security blocked some behavior of your software, but we have whitelisted those rules."
    Host Support: "Thus, everything should work fine now."

    Me: "But was it something I could have changed? Or only you?"

    Host Support: "No, unfortunately, this can be done only from our side."

    EDIT: I also receive this error when I attempt to paste code written from my pc, straight into the template editor in the UI. Any fix for that?
     
    Last edited: Nov 19, 2014
  6. Jeremy

    Jeremy XenForo Moderator Staff Member

    If it's the same permission error, likely still a mod_security issue.
     
  7. vbuser

    vbuser Active Member

    There's probably serveral rules you need whitelisted before things work right.
     
  8. Zaeth

    Zaeth New Member

    Contacted the support again and all issues were solved. Definitely was a mod_security issue.

    Thanks for all the help!
     

Share This Page