1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 File does not exist- style calling style forum rather than a file

Discussion in 'Troubleshooting and Problems' started by aciurczak, Apr 17, 2014.

  1. aciurczak

    aciurczak Member

    I'm trolling through my error logs, and seeing some weird errors. On two subforums, it is triggering a file does not exist error:

    File does not exist: /var/www/html/forums/styles/BP-Black/BP-Black, referer: https://www.crf250l.org/forums/forums/2012-crf250l-tech-talk.17/

    and

    File does not exist: /var/www/html/forums/styles/BP-Black/BP-Black, referer: https://www.crf250l.org/forums/forums/2012-crf250l-farkles.18/

    Both pages look fine, and they look the same as every other subforum on the site, yet only these seem to trigger the error. I've looked in the page source on both, and there is no naked entry to just that directory, so I'm not sure what the problem could be. Any suggestions on where to look?
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    You have an image file missing:

    upload_2014-4-17_10-33-52.png

    Copy it from the default style to your custom style directory.
    Or, remove the reference to it in Style Properties and/or the CSS templates.
     
  3. aciurczak

    aciurczak Member

    Thanks, that helps. But what's weird is that doubling up of the style name. In the path to images for the style, it is just "styles/BP-Black". I'm trying to find where it is showing up in the properties or templates, and haven't found that doubling anywhere. I suppose I can create another set of images directories, at styles/BP-Black/xenforo and at styles/BP-Black/BP-Black/xenforo, but that seems kludgier than trying to find where the actual error is in the properties or templates.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Search in the CSS templates for the image file name.
     
  5. aciurczak

    aciurczak Member

    OK, that helps again, thx. I think we're close, but am still not seeing the problem, even when looking directly at the lines in the template. Perhaps it's before my coffee :) It does show up in 3 modified templates, "message.css", "xenforo_data_table.css", and "xenforo_popop.css". Here's an example of the original code in message.css:

    Code:
    
    customized:
    
    border: 1px solid #202020;
        background: #202020 url({xen:property imagePath}/xenforo/gradients/category-23px-light.png) repeat-x top;
    
    original code:
    
    border: 1px solid {xen:property primaryLighter};
        background: {xen:property primaryLighterStill} url({xen:property imagePath}/xenforo/gradients/category-23px-light.png) repeat-x top;
    
    Same with xenforo data table
    
    customized:
    
    background: #202020 url("{xen:property imagePath}/xenforo/gradients/category-23px-light.png") repeat-x top;
    
    original:
    
    background: {xen:property primaryLightest} url("{xen:property imagePath}/xenforo/gradients/category-23px-light.png") repeat-x top;
    
    customized:
    
    background: #202020 url("{xen:property imagePath}/xenforo/gradients/back1.png") repeat-x top;
    
    original:
    
    background: {xen:property secondaryLighter} url("{xen:property imagePath}/xenforo/gradients/category-23px-light.png") repeat-x top;
    
    Finally, xenforo_popup.css:
    
    customized:
    
    background: #202020 url('{xen:property imagePath}/xenforo/gradients/category-23px-light.png') repeat-x top;
    
    original:
    
    background: {xen:property primaryLighterStill} url('{xen:property imagePath}/xenforo/gradients/category-23px-light.png') repeat-x top;
    
    
     
    Last edited: Apr 17, 2014
  6. aciurczak

    aciurczak Member

    In the meantime I did duplicate that one file, another directory down, and the error did go away as expected. I still don't have a great understanding of what I'm missing, though...
     
  7. aciurczak

    aciurczak Member

    Hang on - I see a difference, the first two are using " while the last is using '. It appears to be an error in the unmodified code as well, right?
     
  8. aciurczak

    aciurczak Member

    Still stumped. I changed all references to have " in them, and it didn't fix the problem. I then changed all references to ' instead, and that didn't fix the problem. What's weird is the change didn't seem to break or fix anything else either. I then put the dupe image file back in the secondary directory, and the error goes away (because it is still searching in that weird place). Will come back and play with this some more when I have a moment. It's a weird glitch, but isn't causing any user or site issues so I probably have more important things to worry about.
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

    Is this a custom style? If so, it may be in one of the CSS templates for it. Do a template search for BP-Black and see if it turns up anywhere.
     
  10. aciurczak

    aciurczak Member

    Yes, it's one of the Blue Pearl styles. But - I think that the template search above would capture any references in all of the templates, including the ones that have been modified by that style, right?
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    It will catch all of them... and you need to review those that have it to see if there is a double listing of BP-Black/BP-Black anywhere. In fact, I would try searching on that first.
     
  12. aciurczak

    aciurczak Member

    Right - I've done all of that already, as posted above? There is no double listing of BP-Black (or any listing of BP-Black, actually, it's all passed through that "imagePath" property).
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    It's not showing on your site in either of those links (nor in the page source code). Are you running APC/Memcached or any other caching mechanism by chance?
     
  14. aciurczak

    aciurczak Member

    I fixed the error by putting in that dupe directory (as listed in post #8), so it shouldn't show up as an error anymore. I am running memcached. It didn't seem to be cache-related (when I have the file in it immediately works, when I rename it fails immediately), but maybe you're seeing something I'm not?
     
  15. aciurczak

    aciurczak Member

    Ah - it took me a second, but I see your point. If I've fixed it within those templates, but they are still cached, the changes/fixes won't show unless I clear the cache. I believe my css files are cached for 60 minutes by default, so if memcache didn't pick up a change, that very well may be something to investigate.
     
    Tracy Perry likes this.
  16. aciurczak

    aciurczak Member

    I'm now clearing the cache on each change, with no effect yet. I did realize that I was swapping the original/customized in my post above. The red is the original and the green is the customized, I thought it was different. Will change that in the post now so it views as correct.
     
  17. aciurczak

    aciurczak Member

    It's still a bit of a mystery. I went in to each of the custom templates, and changed the file name completely, to at least track down where the error was showing up from. I released the cache (with echo 'flush_all' | nc localhost 11211), and the error still showed up as it was. (but also, I didn't see errors from the changed file names, which was weird as well). In the developer console, it's showing that the GET is failing during a jquery call. Does this help narrow the location?

    Capture.JPG
     

Share This Page