1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 FB Integration with XF in a directory

Discussion in 'Troubleshooting and Problems' started by MegaFora, Jul 2, 2014.

  1. MegaFora

    MegaFora Member

    I have one XF 1.3.3 installation that's working perfectly with Facebook integration, and now I'm setting up another one, but in this case XF is in a directory (specifically http://lightpull.org/l ).
    When using the "Test Facebook Integration" tool on this second installation I keep getting:

    Not Found
    The requested URL /admin.php was not found on this server.

    I've tried putting the site url into facebook with and without the /l , and other than that all the settings are identical to the one that works, in both the FB app and in XF (other than different app IDs obviously). Also, I do have an admin.php file in the /l folder.

    Any ideas?
  2. Liam W

    Liam W Well-Known Member

    Where is the test facebook integration URL taking you?

    The Facebook settings have nothing to do with the error you're seeing.

    Check your Apache error log to see if there's another error causing the 404 to be shown.

  3. MegaFora

    MegaFora Member

    The facebook url is taking me to the root, not the /l directory - so it's going to wordpress, not xenforo, and there isn't a suitable admin.php where it's looking. If I select the url with the error and manually add the /l/ it confirms perfectly and returns me to my XF panel and my facebook picture.

    In the facebook app, I already have the site url as http://lightpull.org/l/, but it won't accept a directory as an app domain, which might be why it's looking in the root.

    I could just redirect in htaccess so /admin.php* redirects to /l/admin.php*, couldn't I? There must be a better way though - presumably a lot of people run XF in a directory so it can't be an unusual situation.
  4. Mike

    Mike XenForo Developer Staff Member

    Sounds like your "Board URL" setting is wrong in XF.
  5. MegaFora

    MegaFora Member

    So it is. Works perfectly now. Cheers Mike.

Share This Page