1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fatal Error While Installing XenForo

Discussion in 'Installation, Upgrade, and Import Support' started by DistortedDorian, Oct 13, 2013.

  1. DistortedDorian

    DistortedDorian Active Member

    Hello, i'm unsure if this is right section, anyway i just punched a Xenforo license and while installing Xenforo on my Windows 7 OS i'm getting Fatal Error (look at picture), i'm using WampServer 2.4.
    I have Wamp in Online mode and i downloaded latest version of Xenforo, when i'm trying to reconnect to localhost:8080 i get this error: "An unexpected database error occurred. Please try again later."
    What is wrong?

    Attached Files:

  2. Brogan

    Brogan XenForo Moderator Staff Member

    This is not a bug so I have moved the thread.

    You will need to tweak the settings to more than 120 seconds, possibly others too.
    I had to optimise my XAMPP configuration quite a bit.
  3. Mike

    Mike XenForo Developer Staff Member

    It's worth noting that on a "normal" server, this step shouldn't take more than a few seconds. It's creating the necessary parts of the database. It sounds like MySQL may need some optimization locally, or setting the time limit higher.
  4. DistortedDorian

    DistortedDorian Active Member

    @Brogan @Mike
    Where exactly can i change that?
  5. Mike

    Mike XenForo Developer Staff Member

    Actually it looks like that limit is set in the code so I don't think you can change that without editing the code. I had another server today where this step was particularly slow and have made some tweaks for 1.2.3 to help this.

    I'm not sure what sort of setup or configuration Wampserver uses. You could potentially try a different bundle (eg, Zend Server: http://www.zend.com/en/products/server/) or setting up MySQL directly. MySQL can be configured via a my.cnf file though this is a fairly advanced procedure.
  6. DistortedDorian

    DistortedDorian Active Member

    I'm stuck, i tried add
    ini_set('max_execution_time', 500); to my library/config.php, max_execution_time: 90 in my php.ini and
    php_value max_execution_time 500 inside of library/.htaccess, these options i add are being reseted when the installation starts, what else can i do?
    Is Zend Server used for Windows 7?
  7. Mike

    Mike XenForo Developer Staff Member

    Yes, you can run it on Windows 7.

    Unfortunately, I don't really have any suggestions other than playing with some MySQL settings (as more than 120 seconds for that step is at least an order of magnitude slower than it should be), waiting for 1.2.3 which handles slower table creations more gracefully, or doing the install on a different server.
  8. DistortedDorian

    DistortedDorian Active Member

    But exactly where is the option to change the 120 second timeout, is it inside of mysql config, apache, php or somewhere in phpmyadmin?
  9. Mike

    Mike XenForo Developer Staff Member

    I mentioned that in a slightly earlier post:
    It's specifically in library/XenForo/Install/Controller/Abstract.php.
  10. DistortedDorian

    DistortedDorian Active Member

    I installed a extended version of WampServer and now the website succesfuly installed! Thank you and @Brogan for all help!
    Mike likes this.

Share This Page