1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Fatal Error when deleting forums in the ACP.

Discussion in 'Resolved Bug Reports' started by Ruven, Oct 8, 2010.

  1. Ruven

    Ruven Well-Known Member

    "Fatal error: Maximum execution time of 60 seconds exceeded in /home/ruven76/public_html/paola/library/XenForo/Model/Permission.php on line 1556"


    Whats this about?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Does that forum have a lot of threads in it? Because it appears to be taking a while to delete. If it has lots of threads then you can try to break up the job by pruning threads in batches on the front end using inline moderation.

    Or you can ask your host to increase PHP's max_execution_time.

    You can also try adding this to your library/config.php file:

    Code:
    ini_set('max_execution_time', 300);
    
    Or try adding this to a .htaccess file on your server (only works on Apache servers):

    Code:
    php_value max_execution_time 300
    
     
  3. Ruven

    Ruven Well-Known Member

    This is only a test server, i imported my vb4 DB but left the posts/threads off.
    I just wanted to see how the forum structure is with subforums and what not.
    Ill check the other options you gave me.
    Thanks for the tip, ill be back with the results.
     
  4. Ruven

    Ruven Well-Known Member

    Ok, i tried adding to my config.php file.
    When i went to my site i got the following message....


    An unexpected exception occurred

    So now to plan B.
     
  5. Ruven

    Ruven Well-Known Member

    After trying going the htaccess file route i got this error in a xenforo overlay...

    Uncaught Error...

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, webmaster@dailysportspages.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
     
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The .htaccess file doesn't always work. It depends on the server configuration.

    You said you didn't import the threads and posts so I don't know why it would take longer than 60 seconds to delete the forum. I tried to reproduce the problem by running my own import without threads and posts. Deleting imported forums worked fine for me. But I am importing from vB3, not vB4. Technically there is no vB4 importer yet. Maybe it's a problem related to that.

    I don't know what else to suggest.
     
  7. Ruven

    Ruven Well-Known Member

    Thanks Jake.
    Im still having this issue, cant figure it out.
    I raised the time limit in php.ini and now the ACP just hangs for longer time :D
     
  8. Paul M

    Paul M Well-Known Member

    Try viewing the mysql processlist and see if its something in mysql taking a long time to run.
     
  9. Ruven

    Ruven Well-Known Member

    This is what i got Paul M.


    mysql> show full processlist;
    +--------+-----------------+-----------+-----------------+---------+------+-------+-----------------------+
    | Id | User | Host | db | Command | Time | State | Info |
    +--------+-----------------+-----------+-----------------+---------+------+-------+-----------------------+

    | 222300 | root | localhost | NULL | Query | 0 | NULL | show full processlist |
    | 222470 | ruven76_xenforo | localhost | ruven76_xenforo | Sleep | 0 | | NULL |
    +--------+-----------------+-----------+-----------------+---------+------+-------+-----------------------+
    2 rows in set (0.00 sec)
     
  10. Mike

    Mike XenForo Developer Staff Member

    Moving this to bugs so we look into it further. It appears to have stopped during a permission rebuild (which can be an intensive process), though it may have spent 95% of the time stuck elsewhere.
     
  11. Ruven

    Ruven Well-Known Member

    I dumped my test site and started over from scratch.
    This time i did import the posts and threads, and i also used Paul M's import tool instead.

    The import kept dying at random spots, had to refresh it a lot of times, took a few hours.
    But that was nothing.
    Since the problems continued after the import and the automatic indexing that happens after the import, i decided to run the index tool on everything one by one.
    Now THAT was a chore. Specially when it got to threads/posts.
    I spent most of the evening doing that, all through the night and into the morning.
    It kept stalling/timing out at random times, sometimes every 15-20 minutes or so, then it would be good for an hour, then another rash of it crashing.
    Eventually it was finished.
    And now stuff does delete, yay!
    But it takes a looong time to do so, and it never leaves the "deleting" overlay in the ACP.
    It just stays working on the deletion forever. But after a good chunk of time has passed and you hit cancel then refresh the page... the section you wanted gone is now deleted.

    I know my DB is kinda big, but deleting stuff works fine in vBulletin, there's no reason it should be this slow with XF.
    Even creating/importing styles and deleting brand new forums or pages takes a good 3 to 5 minutes. That should be quick.
    Before i do an import everything seems to work fine.
     
  12. Mike

    Mike XenForo Developer Staff Member

    I actually changed the permission rebuild stuff a few versions ago and sped it up quite significantly. This issue should be resolved now.
     

Share This Page