1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Fatal error: Maximum execution time of 30 seconds exceeded

Discussion in 'Troubleshooting and Problems' started by farmglitch, May 8, 2014.

  1. farmglitch

    farmglitch Active Member

    Has anyone seen this error before. I get it when I try and send out emails or clean up my users waiting for approval. Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\library\Zend\Mail\Protocol\Abstract.php on line 364

    Thank you
     
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    You should reduce the batch size when sending emails.
     
    farmglitch likes this.
  3. ENF

    ENF Well-Known Member

    It happens if you're doing a large group, you can adjust the timeout settings in your PHP settings.

    The default, usually 30 seconds, can be extended to a more reasonable amount to allow the system to finish processing.

    You can try extending it in increments of 30 seconds to see if it will be enough.

    Your other option is to do less at one time.

    Refer to this PHP doc for more information about the settings.
     
    farmglitch likes this.
  4. farmglitch

    farmglitch Active Member

    This problem has been resolved. Both of these are good answers thank you.
     

Share This Page