1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Fatal error creating admin account during installation.

Discussion in 'Resolved Bug Reports' started by Tigratrus, Oct 6, 2010.

  1. Tigratrus

    Tigratrus Well-Known Member

    Call to undefined function iconv_get_encoding() in /home/our_domain_name/public_html/xf/library/Zend/Validate/Hostname.php on line 513

    Any ideas?
  2. JVCode

    JVCode Well-Known Member

    Having the same issue, apparently it's my setup. Not sure how or why :)
  3. Tigratrus

    Tigratrus Well-Known Member

    :: Ponder ::
    Have to go do the night time routine with the kids, then I'll be back and start poking... Have you tried tailing your error log to see if anything useful comes up there when it errors?
  4. Shamil

    Shamil Well-Known Member

    Try setting the mysql server to rather than localhost. Server might be using IPv6
  5. Floris

    Floris Guest

    So in your professional opinion. He should change the host to an ipv4 address because the server might be ipv6?

    Photomedium, Forsaken and Mikey like this.
  6. Dan

    Dan Well-Known Member

    Same issue. It appears that my PHP wasn't compiled with iconv. Recompiling now
  7. Lawrence

    Lawrence Well-Known Member

    It sounds like when php was compiled it didn't have all the packages. You will need to recompile it.
  8. Tigratrus

    Tigratrus Well-Known Member

    hrm... I'll have to tackle that when I get back from doing the bedtime routine with the kids. Thx goblues! :)
  9. Dan

    Dan Well-Known Member

  10. Tigratrus

    Tigratrus Well-Known Member

    Recompiled php on our testbed sever to add iconv support and the rest of the install was a snap.
    Backend admin is awesome :)
  11. Mike

    Mike XenForo Developer Staff Member

    Looks like iconv is going to be required. I didn't realize how extensively Zend Framework uses it. Additionally, without it, imports could have more errors.

    It's on by default in PHP 5, so you either need to manually disable it or use a package that disables it. In the latter case, you probably have a package that can add it.

    If you are unable to get iconv installed on your server and can't install the software, contact us and we'll see what we can do.

Share This Page