• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Duplicate  Fatal Error

JVCode

Well-known member
#1
Fatal error: Call to undefined function iconv_get_encoding() in /home/*******/public_html/*********/library/Zend/Validate/Hostname.php on line 513

I get this error once I've submitted my create admin info during setup.
 

JVCode

Well-known member
#3
I have ran the file Mike posted, which is why I didn't think this problem was related to my server configuration.
 

Tigratrus

Well-known member
#5
I've got the same exact error on mine. I can PC a php info page link if it would help? For obvious reasons I'd rather not post it in the public thread ;-)
 

JVCode

Well-known member
#8
Thanks for the solution, I'm using xenForo on a shared server right now, I have no idea how I'd recompile php or anything, someone care explain?
 

Jake Bunce

XenForo moderator
Staff member
#9
Thanks for the solution, I'm using xenForo on a shared server right now, I have no idea how I'd recompile php or anything, someone care explain?
On a shared server you would have to ask your host to do it. It requires root access.
 

Dan

Well-known member
#10
Thanks for the solution, I'm using xenForo on a shared server right now, I have no idea how I'd recompile php or anything, someone care explain?
You will have to ask your host to do this for you. Sorry Jake, you beat me to it.
 

Mike

XenForo developer
Staff member
#12
I noted this in another bug, but it looks like iconv is required. If you're having trouble installing because of it being missing, contact your host. If you're still having trouble, contact us and we'll see what we can do.