1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Fatal Error at signup

Discussion in 'Resolved Bug Reports' started by Programmer, Oct 6, 2010.

  1. Programmer

    Programmer New Member

    Hello, everyone!

    At signup, I get the following error:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 369744134 bytes) in /home/*******/public_html/library/XenForo/Template/Abstract.php(206) : eval()'d code on line 594

    Once CAPTCHA is disabled, I don't get the above error but the following:

    XenForox - Error
    This action is available via POST only. Please press the back button and try again.

    Let me know what needs to be done to get this fixed.

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is probably the result of you trying to directly load the URL of the registration form. You have to go through the initial Log in or Sign up form instead. Or if you are already on the registration page and you want to refresh then be sure to use the refresh button in your browser (as opposed to directly submitting the URL again).

    Does CAPTCHA have any effect on the memory error now?

    The error appears to have something to do with the templates but I'm not sure how to proceed.
  3. Programmer

    Programmer New Member

    Thanks for the reply =]

    The memory error only appears when CAPTCHA is enabled and Friendly URLs are disabled.
    Once I enabled Friendly URLs, the memory error's gone but I still get the below message:
  4. PGU

    PGU Member

    i received this as well when people try to register with the drop down sign up link. i have yet to figure out why.
  5. Floris

    Floris Guest

    I'm waiting for a fix, I assume they're working on it - poked them earlier on Skype.
  6. Programmer

    Programmer New Member

    That's not the problem, the signup/register page just doesn't display.
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Hmm. The entire registration system works fine on my forum, with and without captcha.
  8. Peggy

    Peggy Well-Known Member

    Works fine on mine, as well.
  9. Floris

    Floris Guest

    doesnt work here, still. when logged out - i get the most errors. and mike could reproduce it.
  10. lazer

    lazer Well-Known Member

    +1 same issue when registering a new account.

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 369744134 bytes) in /home/*****/public_html/forum/library/XenForo/Template/Abstract.php(206) : eval()'d code on line 594
  11. Louis

    Louis Member

    Exactly same error for me too. I'm hosting with Hostgator if that makes a difference.
  12. lazer

    lazer Well-Known Member

    Did anyone get anywhere with this yet?

    EDIT: Seeing Kiers post here: http://xenforo.com/community/threads/500-error-on-signup.5051/#post-81817 I tested the Contact Us form as a visitor and it worked perfectly - email received. Still getting the above error on registration though.

    2nd EDIT: Interesting...if I click on an attachment and receive the "You must be logged in" error - then subsequently go through to sign-up IT WORKS!
    However, it's still showing the error as above when signing up thru the header dropdown method.
  13. Floris

    Floris Guest

    Very strange issue :(

    However, last night after few hours I dropped the database, put htaccess protection up and uploaded the .zip to the server, unpacked on server and walked through install without errors.

    I haven't seen the issue since. so i removed htaccess, went to bed. i woke up - wihtout many msgs that it errors. so i dunno if i got lucky or if it is fixed.
    lazer likes this.
  14. lazer

    lazer Well-Known Member

    Believe it or not, I just tried the header registration again (with no changes to the boards or backend) and it's now working with no error. :confused:
  15. Programmer

    Programmer New Member

    You guys got lucky then :D

    I'll do what you did and see if that solves the problem :)
  16. Mike

    Mike XenForo Developer Staff Member

    There seems to be some evidence that this may be related to the install issues (the timeout: 2000 thing). If it goes away after a reinstall, that is likely the case.

    Though I have to admit I'm not sure why...
  17. Programmer

    Programmer New Member

    Yes, that's what caused this problem along with others (error when creating new languages)
  18. jmurrayhead

    jmurrayhead Well-Known Member

    I just got the "This action is available via POST only. Please press the back button and try again." error when I reset my password. Steps: used the Forgot Password form, clicked the link in the email, received new password, updated password. After I updated my password is when the error occurred.

Share This Page