1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Fatal Error: Allowed memory size

Discussion in 'XenForo Questions and Support' started by gotski, Sep 8, 2015.

  1. gotski

    gotski Member

    Hello, lately sometimes I received this error, today I received near 25 errors,
    I don't know why, but I receive this errors after update to XF 1.5. How I can fix this?


    ErrorException: Fatal Error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 34468289328 bytes) - Unknown:0
    Generated By: Unknown Account, 6 minutes ago

    array(3) {
    ["url"] => string(98) "http://www.mydomain.net/community/css.php?css=xenforo,form,public&style=1&dir=LTR&d=1441720464"
    ["_GET"] => array(4) {
    ["css"] => string(19) "xenforo,form,public"
    ["style"] => string(1) "1"
    ["dir"] => string(3) "LTR"
    ["d"] => string(10) "1441720464"
    }
    ["_POST"] => array(0) {
    }
    }
     
  2. borbole

    borbole Well-Known Member

    The error indicates that you are running out of memory. Are you on a shared host or do you have your own vps/dedicated box?
     
  3. gotski

    gotski Member

    I have a own dedicated server
     
  4. Arty

    Arty Well-Known Member

    How many styles do you have installed on your forum?
     
  5. gotski

    gotski Member

    Only one, default style
     
  6. Arty

    Arty Well-Known Member

    Weird. XenForo uses a lot of memory when parsing many styles, but with 1 it shouldn't use so much memory.

    Maybe its a buggy add-on? Try disabling add-ons.
     
  7. gotski

    gotski Member

    Nope I don't have a addons except the official (xf media gallery 1.1), I only have some template modifications
     
  8. Mike

    Mike XenForo Developer Staff Member

    Looks to me more like a PHP issue itself, given that it wants to allocate ~34 GB. It also isn't happening in a specific file.

    I would look at restarting your web server/PHP-FPM. There may be opcode cache corruption.
     
  9. gotski

    gotski Member

    I ask they, he say it maybe problem in script.... they offered php_admin_value mbstring.func_overload 6 (read about it on XF forum ) after enable.... main forum styles die (background, responsive) styles for threds forum list work fine, I don't know why =)
    Screen from admin page after enable func_overload
    Untitled-1-Recovered.jpg
     
  10. Mike

    Mike XenForo Developer Staff Member

    That would have been relevant. Never enable mbstring function overloading. I'm not sure where you saw that recommended.
     
  11. gotski

    gotski Member

    Not me.... My hosting support.
     

Share This Page