1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Failed: Upgrade from older version to 1.4.1.

Discussion in 'Installation, Upgrade, and Import Support' started by Tarzan, Jun 3, 2015.

  1. Tarzan

    Tarzan Member


    Short story: I wanted an add-on. Tried to install it. Said that I had old version of Xenforo. Downloaded upgrade folder of Xenforo, extracted, uploaded and installed. Installed two add-ons. Then there was problems.

    I appreciate any help I get.

    • I can't create any replies or create conversations. Reason: There is no "text box" to type in.
    • I often get redirected to /run-deferred/ if i try to change anything at the ACP.
    • Themes/styles are outdated, trying to "merge changes" will result in Permission Denied page "You don't have access to /admin.php" on this server.
    • Setting the Default Style to default, will not work. It pops back to the current one.
    Possible solutions:
    • Upload backup of the old forum version; before I started the upgrade process.
    • Feedback from you at the forums
    • Moderator can get admin details

    Description: Outdated paged

    Desctription: No text box when replying at a post

    : No text box in a conversation

  2. Brogan

    Brogan XenForo Moderator Staff Member

    You have a lot of outdated templates which you will need to resolve.

    You can either attempt to merge them, or if that won't work, revert and reapply your customisations.
    If they're from a third party style though, you should upgrade to the latest version which will resolve it.

    Any third party add-ons will need to be updated to the latest compatible version, if there is one available.
  3. Tarzan

    Tarzan Member

    If I try to merge I get this error:
    Yes, it's a third-party style. Let's do it the easy way and say I want the default one so there is no problems with style. How do I come about the problem I have which won't let me change to "Default Style".
  4. Brogan

    Brogan XenForo Moderator Staff Member

    That error is typically related to mod security (or similar).

    Explain it to your host and they should be able to resolve it.

    If you just want the default style, select it if it exists, otherwise create a new style without a parent.
  5. Tarzan

    Tarzan Member

    Thank you. I've sent my host a support ticket, and it will hopefully be resolved.

    I'll come back with answers as soon as I get any.
  6. Tarzan

    Tarzan Member

    Is it a big problem if I upgraded directly to 1.4 from 1.2?

    I see that there is an option for this on "importing" in the import guide. What happens if I directly upgraded?
  7. Brogan

    Brogan XenForo Moderator Staff Member

  8. Tarzan

    Tarzan Member

    Thank you for your help.

    I haven't been able to resolve the issue, but my host helped me to restore everything as the way it was before.

    I will create a seperate forum later with it's own database to see if I get the same problems.

    This thread can be locked, I will make a new one when the time comes.

Share This Page