• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 Error installing older version of XF

#1
Long story short i'm trying to make a site using an older version of xf (1.1.1 to be exact). The error comes along when I have to setup the administrator account. I really want to know if theres a way to fix this.

This is the error

Server Error
Server Error
Validate class not found from basename 'EmailAddress'

  1. Zend_Validate::is() in XenForo/DataWriter/User.php at line 572
  2. XenForo_DataWriter_User->_verifyEmail()
  3. call_user_func_array() in XenForo/DataWriter.php at line 965
  4. XenForo_DataWriter->_runVerificationCallback() in XenForo/DataWriter.php at line 720
  5. XenForo_DataWriter->_isFieldValueValid() in XenForo/DataWriter.php at line 638
  6. XenForo_DataWriter->set() in XenForo/DataWriter.php at line 978
  7. XenForo_DataWriter->bulkSet() in XenForo/Install/Model/Install.php at line 216
  8. XenForo_Install_Model_Install->insertAdministrator() in XenForo/Install/Controller/Install.php at line 274
  9. XenForo_Install_Controller_Install->actionStep3b() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home/d3fault/public_html/test/install/index.php at line 18
Please don't respond with (Just use a newer version) because there are specific reasons to why i'm using such an old version. Unless 1.1.1 is just broken now and doesn't work. Thanks in advanced.

Also just to knockout some possible answers (I've uploaded everything in binary, set the correct permissions for the Internal_data and data folders and have made sure my MySQL info is correct)
 
Last edited:

Brogan

XenForo moderator
Staff member
#2
Check that all of the files have been uploaded correctly.

The other possibility is some sort of security/configuration issue in PHP.
 
#3
Check that all of the files have been uploaded correctly.

The other possibility is some sort of security/configuration issue in PHP.
Yeah i'm positive the files have been uploaded correctly. I've tried on two different hosts, with two different FTP clients using multiple zip files from different versions (the only one i've gotten to work is 1.4.2). If it is a configuration issue in PHP how would I go about fixing that?
 

Brogan

XenForo moderator
Staff member
#4
You would likely need to get your sysadmin or host to investigate.

Essentially though, our recommendation would be to install the latest available version you have access to - XF 1.1.1 is over 5 1/2 years old now.
 
#5
You would likely need to get your sysadmin or host to investigate.

Essentially though, our recommendation would be to install the latest available version you have access to - XF 1.1.1 is over 5 1/2 years old now.
So i've went back and looked more into it, i've noticed that it installs everything and it all works except for making an account, whether it be the super admin or a regular user. It could also be related to the installation process stopping right after it says "Rebuilding...Email Templates". Could that possibly narrow down a fix for this or do you not know what the error means?
 
#6
You would likely need to get your sysadmin or host to investigate.

Essentially though, our recommendation would be to install the latest available version you have access to - XF 1.1.1 is over 5 1/2 years old now.
I just got it to work by changing my PHP version from 5.6 to 5.4, thought i'd let you know incase anyone else runs into the same issue. Thanks for your help.