Resource icon

Facebook OpenGraph Image from [img] or [attach] tags 1.3

No permission to download

BobbyWibowo

Well-known member
Then most likely because of that. There are threads in my forums with thumbnail-only attachments and the first attachment was finely detected by the add-on.
 

BobbyWibowo

Well-known member
If you want to disable avatar, you'll have to edit open_graph_meta template and find the line that adds avatar and remove it. If you want to remove xenforo logo, it's better to revert my customization or change the default logo as documented here. My customization was so that it's possible for user to still choose the logo if they don't want to use attachment picture when they share my forums on Facebook.
 

otto

Well-known member
Hello,

nice addon, works with a litle bit custom code like a charm. :)

Is there a way to adapt this also for Xenforo Ressource Manager ressources to use attached images in ressources also as Opengraph image on FB?

Regards
 

rafass

Well-known member
I've been testing while ago with that code, trying to remove those [ATTACH ]'s but doesn't work here. :r
Screen Shot 2016-05-26 at 4.56.57 PM.png
 

BobbyWibowo

Well-known member
If the code from the thread we linked before could work, then it's easy to remove both BBCode tags and Smilies. They both have patterns, so we can easily use regex instead.
 

CrispinP

Well-known member
this works quite well. I have modded it a bit if the author is interested. I've sent the code to the author so he can update it and release it.

Now, if you a youtube video embedded in the post it will get the default screenshot from youtube and use that as a og:image URL.

Example:
My thread (https://www.landcruiserclub.net/community/threads/proper-stuck.145659/) only has a youtube video embedded in it.
The og:image is that of the sunken landrover a few posts down. I don't want that :)

So now the plugin returns https://img.youtube.com/vi/cM_vjHgPfm0/0.jpg which is the default image for the video.
Much nicer :)
 

BobbyWibowo

Well-known member
Ohho, nice idea. So it is:
Code:
https://img.youtube.com/vi/VIDEO_ID/0.jpg
I suppose I'll be implementing this extra to a similar add-on which I'm currently working on. Thanks for the idea!
 

CrispinP

Well-known member
That's exactly it. I've emailed the author and given him the code to update. If I don't hear back then I'll release an updated version.

I did find fb a bit temperamental and complained that the image response was too slow. It then refused to load it. I've a few ideas on how to solve that but will see how it goes.
 

BobbyWibowo

Well-known member
Does 0.jpg always the same as hqdefault.jpg? I have kinda finished my add-on which is sorta packed with extra features requested by someone else. But for the extra feature of adding YT thumbnail, I kinda used hqdefault.jpg instead of 0.jpg.
 
Top