• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Facebook API complicance

#1
It seems Xenforo is not compliant with new facebook api changes. Will you be issuing a patch in the next few weeks?

Your app, White Rabbit Community Forums has not enabled the migration for the July 2013 Breaking Changes.
Once you have confirmed your app is compliant or unaffected by the July 2013 Breaking Changes, set the migration setting to "Enabled" in the Advanced section of the App Dashboard. This will apply the July 2013 Breaking Changes to your app and prevent you from receiving future alerts about these changes.
White Rabbit Community Forums, is currently using the following deprecated features:
  • Social Plugins (Like Button, Like Box) without absolute URL's in their `href` parameter.
These changes will be permanently enabled for all apps in 57 days on Thursday, July 11, 2013.
https://developers.facebook.com/roadmap/
 

Chris D

XenForo developer
Staff member
#3
For anyone else getting these alerts, the solution is simple.

Go to your App Dashboard and set the July 2013 Breaking Changes to Enabled.

Worst case scenario: Something breaks. Disable the changes and report it as a bug with either the add-on developer or in this forum.

Best case scenario: Nothing breaks. The continued alerts from Facebook will cease.
 

Andrej

Well-known member
#6
they specifically say what the issue is


if that's not a problem, maybe xenforo should submit a bug report to facebook for this false positive?
I believe Mike did say clearly above and here, XenForo is unaffected. This notice may apply to other API users outside XenForo.
 

Mike Edge

Well-known member
#8
if that's not a problem, maybe xenforo should submit a bug report to facebook for this false positive?
Because this is not a false positive. Every facebook app get's that warning message. It has nothing to do with xF or any code for that matter. Just click it's fixed and continue on. As Chris stated already too, you can simply go into your dashboard and enable July 2013 Breaking Changes to know 100% it still works.