1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Errors during a password reset?

Discussion in 'Troubleshooting and Problems' started by shawn, Mar 15, 2013.

  1. shawn

    shawn Well-Known Member

    I get requests from users to reset their passwords for them on a fairly regular basis. No problem. I open up the forum in an incognito tab, plug their email address into the forgotten password form, then send them an email explaining the process. They'll get an email from the server, check their spam folder, click the link, etc, etc.

    The problem is... about half of the time, they respond that this method "didn't work" and they got "an error". I've never been able to get any more specific information out of them, and try as I might, I can't replicate the issue myself.

    Has anyone else ever run into it?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Without further details on what the error is, it's difficult to say.

    Can you get one of them to forward the email to you?
    That may shed some more light on it.
  3. shawn

    shawn Well-Known Member

    The email they're getting is just the regular xf password reset one. Apparently, they're getting an error with they click the validation link that actually does the password resetting.

    And as you can imagine, a user that can't reset his own password doesn't suddenly become a font of knowledge when something like this happens.

    I'm mostly fishing... figured maybe somebody else had seen it once in a while, we could guess at what was causing it, and then send Mike off after the problem. ;)
  4. shawn

    shawn Well-Known Member

    The only thing I can come up with is that they're clicking the link twice and seeing an error relating to the reset having expired on the second go-around. But if that's the case, they should still be getting an email with the new password in it.
  5. Mike

    Mike XenForo Developer Staff Member

    It's generally that your board URL setting is incorrect. Seeing the actual email would help.
  6. shawn

    shawn Well-Known Member

    This is the one I sent myself earlier today:

    And it worked fine. But the one I sent to another user last night didn't work. None of the "basic" board settings have changed in months... maybe not since the initial migration.
  7. shawn

    shawn Well-Known Member

    Or maybe they're trying to copy/paste the URL and they're including (or leaving off) bits that they shouldn't? AKA, 100% user error...
  8. Mike

    Mike XenForo Developer Staff Member

    If it worked for you, it's certainly possible that it's user error. Hard to say if you can't reproduce it consistently.

Share This Page