1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ErrorException: Undefined index: thread_read_date - library/XenForo/ControllerPublic/Thread.php:676

Discussion in 'Troubleshooting and Problems' started by marring, Mar 31, 2015.

  1. marring

    marring Member

    After running for a long time without any error. Recently, I got many errors likes that:

    ErrorException: Undefined index: thread_read_date - library/XenForo/ControllerPublic/Thread.php:676

    Stack Trace
    #0 /home/mydomain.vn/public/library/XenForo/ControllerPublic/Thread.php(676): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/mydomain....', 676, Array)
    #1 /home/mydomain.vn/public/library/XenForo/ControllerPublic/Thread.php(622): XenForo_ControllerPublic_Thread->_getNewPosts(Array, Array, 1413561309, 3)
    #2 /home/mydomain.vn/public/library/sonnbUpThread/ControllerPublic/Thread.php(79): XenForo_ControllerPublic_Thread->actionAddReply()
    #3 /home/mydomain.vn/public/library/EWRporta2/ControllerPublic/Thread.php(35): sonnbUpThread_ControllerPublic_Thread->actionAddReply()
    #4 /home/mydomain.vn/public/library/XenForo/FrontController.php(347): EWRporta2_ControllerPublic_Thread->actionAddReply()
    #5 /home/mydomain.vn/public/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #6 /home/mydomain.vn/public/index.php(13): XenForo_FrontController->run()
    #7 {main}
    Request State
    array(3) {
      ["url"] => string(129) "http://www.mydomain.com.vn/threads/nhan-mua-hang-tu-my-gia-re-free-cong-mua-amazon-phi-ship-9-99-kg-bao-hai-quan.339456/add-reply"
      ["_GET"] => array(1) {
        ["/threads/nhan-mua-hang-tu-my-gia-re-free-cong-mua-amazon-phi-ship-9-99-kg-bao-hai-quan_339456/add-reply"] => string(0) ""
      ["_POST"] => array(9) {
        ["message_html"] => string(145) "<p>cho m xin gia e nay ve ha noi nhe&nbsp;http://www.amazon.com/Rayban-Sunglasses-Aviator-Brown-Gradient/dp/B002B4DRH6/ref=pd_ybh_3#Ask&nbsp;</p>"
        ["_xfRelativeResolver"] => string(120) "http://www.mydomain.com.vn/threads/nhan-mua-hang-tu-my-gia-re-free-cong-mua-amazon-phi-ship-9-99-kg-bao-hai-quan.339456/"
        ["attachment_hash"] => string(32) "f725b2f0f5f71282b175689daf505235"
        ["last_date"] => string(10) "1413561309"
        ["last_known_date"] => string(10) "1427685867"
        ["_xfToken"] => string(8) "********"
        ["_xfRequestUri"] => string(94) "/threads/nhan-mua-hang-tu-my-gia-re-free-cong-mua-amazon-phi-ship-9-99-kg-bao-hai-quan.339456/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
  2. Chris D

    Chris D XenForo Developer Staff Member

    This is likely down to an add-on. Several are mentioned in the stack trace.

    First step is to try and reproduce the issue with all add-ins disabled.
  3. marring

    marring Member

    You mean sonnbUpThread, right?

    @sonnb please!
  4. Mike

    Mike XenForo Developer Staff Member

    It may also be opcode cache corruption as we've seen before. Restarting the web server may help.
  5. marring

    marring Member

    Thanks @Mike !

    I'd tried and monitoring... I will report soon.
  6. marring

    marring Member

    Error still happens.

    I think that the reason from UpThread addons by @sonnb. I will take a deep inspect and report soon!
  7. sonnb

    sonnb Well-Known Member

    Up Thread add-on does nothing with this variable. It does some other stuffs and call the XenForo action, which stated in:
    I suggest you check the suggestion posted by Mike.
    marring likes this.
  8. Tracy Perry

    Tracy Perry Well-Known Member

    That's not the only add-on that was listed. EWRporta2 was also in that stack trace. Try disabling it and see if the error resolves itself.
  9. marring

    marring Member

    @Jaxel please!

    Could you please to double check again your addons? Thanks so much!
  10. marring

    marring Member

    Thanks you!
  11. Jaxel

    Jaxel Well-Known Member

    XenPorta2 does nothing with this variable either; nor does it replace any existing variables in the Add-Reply function.
  12. imthebest

    imthebest Formerly Super120

    Do you have defined any caching in config.php? If so, you might want to restart your webserver and see if that solves your problem. If it doesn't, disable all add-ons and try again. If the problem still happens, it might be a database corruption issue.
  13. marring

    marring Member

    I run caching
    $config['cache']['enabled'] = true;
    $config['cache']['cacheSessions'] = true;
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
    'caching'                       => true,
    'cache_id_prefix'               => 'xf1_',
    'automatic_serialization'       => true,
    'lifetime'                      => 1800

    $config['cache']['backend'] = 'Libmemcached';
    $config['cache']['backendOptions'] = array(
    'compression'   => false,
    'servers'       => array(
    'host'          => 'localhost',
    'port'          => 11211,
    'persistent'    => true,
    'weight'        => 1
    And I tried to restart my server, but it does not help!

    I tried to disable UpThread addon and verything runs smooth. Thanks so much for your helps!
  14. sonnb

    sonnb Well-Known Member

    Several big boards using it without error. Please start conversation with me to see how should we work on it.

Share This Page