XF 2.1 Error while running job, its about addon

progures

Member
What is this and how do i solve it? It doesn't even tell me which addon causes that problem. And in admin panel it keeps showing me you have x of unfinished job run them now, and i run and get this error all the time.

PHP:
LogicException: Add-on is not installed in src/XF/AddOn/AddOn.php at line 653

XF\AddOn\AddOn->postDataImport() in src/XF/Job/AddOnData.php at line 78

XF\Job\AddOnData->run() in src/XF/Job/Manager.php at line 253

XF\Job\Manager->runJobInternal() in src/XF/Job/Manager.php at line 195

XF\Job\Manager->runJobEntry() in src/XF/Job/Manager.php at line 79

XF\Job\Manager->runQueue() in src/XF/Admin/Controller/Tools.php at line 139

XF\Admin\Controller\Tools->actionRunJob() in src/XF/Mvc/Dispatcher.php at line 350

XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257

XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113

XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55

XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2190

XF\App->run() in src/XF.php at line 391

XF::runApp() in admin.php at line 13[
 
Last edited:

Dnyan

Well-known member
i dont know what addon causes this. that is the problem
It is very well mentioned in the error log, kindly do read complete error log from start to end.

If it is creating continues error, try disabling addon one by one starting from newly installed addon and check if the error still persist.
 
Top