1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Error when upgrading

Discussion in 'Installation, Upgrade, and Import Support' started by Hana, Mar 27, 2013.

  1. Hana

    Hana Member

    Server Error
    Mysqli statement execute error : Duplicate entry '415-8' for key 'definition_id_style_id'
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 632
    Zend_Db_Adapter_Abstract->update() in XenForo/Model/StyleProperty.php at line 2283
    XenForo_Model_StyleProperty->importStylePropertiesFromArray() in XenForo/Model/StyleProperty.php at line 2187
    XenForo_Model_StyleProperty->importStylePropertyXml() in XenForo/Model/StyleProperty.php at line 2120
    XenForo_Model_StyleProperty->importStylePropertyDevelopmentXml() in XenForo/CacheRebuilder/ImportMasterData.php at line 45
    XenForo_CacheRebuilder_ImportMasterData->rebuild() in XenForo/ControllerHelper/CacheRebuild.php at line 26
    XenForo_ControllerHelper_CacheRebuild->rebuildCache() in XenForo/Install/Controller/Upgrade.php at line 232
    XenForo_Install_Controller_Upgrade->actionRebuild() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/pwndgame/public_html/install/index.php at line 18

    Is there anyway to fix this by chance?
  2. Brogan

    Brogan XenForo Moderator Staff Member

    maszd and Jake Bunce like this.
  3. Hana

    Hana Member

    I tried running it yet again and it produces the same error. I had most of my add-ons enabled, and thought that disabling them would not matter(as if they weren't updated they'd just not work). I also have around 3-4 styles all of which are installed and only a few are selectable. One is Fusion Gamer with a parent style, and others are ones found here and aren't parents of any style.

    I didn't think to backup either as most upgrades in the past usually never produced errors such as these for me awkwardly enough.

    Edit: Refreshing a lot of times fixed it

Share This Page