RM 1.2 Error when trying to Upload Resource Update File

kingjavo

Active member
I posted a new resource update, but realized the uploaded file was incorrect. There wasn't any way I could see to replace the uploaded file, so I deleted the new version and tried to post the resource update again.

This time, however, I'm seeing the below error when trying to upload the new resource file. It's not the file size. I also checked a number of tables in the database and cleaned out the new release rows afterwards to be sure, but still not working.

Can someone please help?

apf6.PNG
 

kingjavo

Active member
Anyone know a way to see the true behind the scenes error? I'm able to upload a smaller file, but my larger zip files won't upload. I've verified my attachment file size setting and also my extensions to allow zip.

I'll keep poking around, but this is weird. One other note, I've rebuilt cache and tried different browser sessions with no luck.

Lastly, the one thing I notice is when I try to post a resource update, that same one I deleted still shows up pre-filled in the Message and Title fields. I'm thinking it's still in the system somewhere... either via cache or database.
 

Mike

XenForo developer
Staff member
The tips in that thread really are the main steps you need to take, though it's possible that there can be limits within the web server or other steps before PHP loads. Note that if you are changing these settings in PHP, you will likely need to restart your web server/FastCGI server for the changes to apply. You should confirm the changes have applied via phpinfo output.
 

kingjavo

Active member
The tips in that thread really are the main steps you need to take, though it's possible that there can be limits within the web server or other steps before PHP loads. Note that if you are changing these settings in PHP, you will likely need to restart your web server/FastCGI server for the changes to apply. You should confirm the changes have applied via phpinfo output.
Still not working. :(

Any other thoughts? Can you log into my site as an admin and check things out for me?
 

Mike

XenForo developer
Staff member
Look at your PHP info -- <url>/admin.php?tools/phpinfo -- and confirm whether the values are showing as you expect. If they are, then there's a possibility that the request data is getting dropped before it even reaches PHP. There are multiple potential triggers for this depending on web server config. (Or things like reverse proxy limits.)
 

kingjavo

Active member
Look at your PHP info -- <url>/admin.php?tools/phpinfo -- and confirm whether the values are showing as you expect. If they are, then there's a possibility that the request data is getting dropped before it even reaches PHP. There are multiple potential triggers for this depending on web server config. (Or things like reverse proxy limits.)
I noticed post_max_size is set to 8M on the -- <url>/admin.php?tools/phpinfo -- page. Is that an issue? I upload the php.htm file but changed the extension to .txt so it can be uploaded.

Can you please take a look and tell me if you see anything else?

Thanks!
 

Attachments

Mike

XenForo developer
Staff member
That's likely the issue. It doesn't look like your INI changes have applied. You may need to edit the main php.ini file directly. Look at the "Loaded Configuration File" and "Scan this dir for additional .ini files" values. You should be able to change the post_max_size and other values there (likely in the main php.ini file itself).
 
Top