• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Error when trying to run the final install.

I`m trying to upgrade from 1.1.5 to 1.2.2 so I have uninstalled all the existing add ons & then Uploaded & overwritten all the files in the 1.2.2 upgrade pack & when browsing to the install directory to complete the install I`m getting the following error

An exception occurred: Cannot send headers; headers already sent in /homepages/11/d374386031/htdocs/wsb6420136202/forum/library/Lgpl/utf8.php, line 4 in /homepages/11/d374386031/htdocs/wsb6420136202/forum/library/Zend/Controller/Response/Abstract.php on line 321

  1. Zend_Controller_Response_Abstract->canSendHeaders() in Zend/Controller/Response/Abstract.php at line 115
  2. Zend_Controller_Response_Abstract->setHeader() in XenForo/ViewRenderer/Abstract.php at line 63
  3. XenForo_ViewRenderer_Abstract->__construct() in XenForo/ViewRenderer/HtmlInstall.php at line 16
  4. XenForo_ViewRenderer_HtmlInstall->__construct() in XenForo/Dependencies/Install.php at line 73
  5. XenForo_Dependencies_Install->getViewRenderer() in XenForo/FrontController.php at line 537
  6. XenForo_FrontController->_getViewRenderer() in XenForo/FrontController.php at line 141
  7. XenForo_FrontController->run() in /homepages/11/d374386031/htdocs/wsb6420136202/forum/install/index.php at line 18
I have redownloaded the package from the customer area & re uploaded the files again & get the same error.

Any help would be appreciated.
OK found that Lgpl/utf8.php didn`t copy over correctly so have manually copied that over & can now get to the "upgrade system" page. (y)

Am now getting the "at least 1 file(s) do not appear to have the expected contents" error. I have redownloaded the upgrade package for the third time & still getting this. Is there an easy way to find which file(s) are causing the error to reappear?


XenForo developer
Staff member
Right now it doesn't give detail in the upgrade but it's a limited list. However, there could be other ones that are incorrect -- it checks a limited number of important files related specifically to upgrading. I would have to recommend reuploading everything, ensuring that files are overwritten as necessary.
Thanks for the reply Mike. I`ve had this second error before on a prev upgrade & redownloading the upgrade pack has fixed it but this time I`ve redownloaded the upgrade pack from the XF servers about 7 times today, uploading the entire contents to my host each time (making sure to overwrite the old files) & I`m still getting this. Should I maybe try going via an earlier version?
OK I`ve been at this for the last 6 hours & still getting nowhere fast.

Download upgrade, extract files, FTP files to server, install says 1 file hasnt got the expected contents, Delete zip & extracted files from hard drive, empty recycle bin, redownload upgrade, extract... you get the idea.

I am selecting to overwrite files when reuploading too.

Anyone else had this & can shed any light on the situation?
Well I tried with WinSCP & all files have now copied over correctly & my forum is now back in the land of the living. :D

Many thanks from both myself & my members!