1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error when going to the /install page.

Discussion in 'Installation, Upgrade, and Import Support' started by Clovis, Aug 19, 2013.

  1. Clovis

    Clovis Member

    When I try and upgrade, I get the following error:

    Server Error
    file_get_contents(install/data/phrases.xml): failed to open stream: Permission denied
    file_get_contents() in XenForo/Helper/Hash.php at line 66
    XenForo_Helper_Hash::compareHashes() in XenForo/Install/Controller/Upgrade.php at line 76
    XenForo_Install_Controller_Upgrade->actionIndex() in XenForo/FrontController.php at line 337
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /home/ouabx10m/public_html/install/index.php at line 18
    All I have done is upload the upload file into the web server directory.
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    Looks like files aren't readable by other files on your server. You'll need to update the file permissions to permit it. (I believe 0644 is the recommended permissions).
  3. Clovis

    Clovis Member

    Just checked my FTP client and it looks like when I was uploading the files, the only one that wouldn't go through after countless retries was
    Could it be that? Going to try a manual re-upload not using ftp. :p
  4. Jeremy

    Jeremy XenForo Moderator Staff Member

    That very much could be the reason.

Share This Page