XF 2.2 Error when enabling friendly URLS

AJH

Member
Hello!

I have web hosting with SiteGround. When I enable friendly URLS, I get a 404 error when clicking on one of the forums. What do I need to do to fix this?
 

Muddy Boots

Active member
From what I have read SiteGround allow no access to nginx config files and I cant see in their help that they have it in their control panel as a special nginx add-on - cant find a lot really

id suggest opening a support ticket at SiteGround and pasting the nginx code from the xf manual linked above and ask them where you have to put this
 
  • Like
Reactions: AJH

quimerics

New member
i got the same problem too today, but i got it fixed by that:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride None
Require all granted
</Directory>

and change it to;

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>

then,

sudo service apache2 restart
 
  • Like
Reactions: AJH
Top