1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Error Uploading File After Moving to New VPS

Discussion in 'XenForo Questions and Support' started by rbharathi, Mar 9, 2015.

  1. rbharathi

    rbharathi Member

    Hi :)
    I am facing this error when uploading files,

    The following error occurred
    There was a problem uploading your file.

    I am hosting my forum on a VPS,

    searched through the forum, every one mentioned about mod_security?
    but cant get the steps to fix on a VPS,

    can i fix this from my VPS?,
    between i am using Cpanel WHM.

    i have tried disabling flash uploader, its not working for larger files,

    i set max_execution_time is 1800 ,

    is this related to max_input_time too?

    small files are uploaded but large files are throwing this error,

    I have set 64MB as post max size,
    files are within 60MB only.

    someone give me hint :)
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Since it happens on large files there must be a limit somewhere.

    Here are some server settings which might be limiting:

    PHP (can be viewed at admin.php?tools/phpinfo):
    max_execution_time
    memory_limit
    post_max_size
    upload_max_filesize

    MySQL:
    max_allowed_packet
    max_packet_size
    wait_timeout

    Incidentally, does it only happen for images or all files? If it's only images then the graphics library might be in play:

    Admin CP -> Home -> Options -> Attachments -> Default Image Processor
     
    rbharathi likes this.
  3. rbharathi

    rbharathi Member

    Hi Jake,
    Thank you for response ,
    partially i cleared this issue by increasing max_upload_size to 128MB,


    still i am getting that error for some files,
    Trying mp4 files,
    checked with 4 or 5 files,
    3 of them uploaded but 2 of them giving error..!!
    is there any ways to debug the error??
     
  4. rbharathi

    rbharathi Member

    I can upload larger files on wordpress sites that hosted in my VPS,
    so i am facing this error with xenforo only??
    any help???
     
  5. Mike

    Mike XenForo Developer Staff Member

    Please try disabling the Flash uploader in your options to see if it still happens.
     
    rbharathi likes this.
  6. rbharathi

    rbharathi Member

    When i disable the flash uploader, i got the error,

    "The following error occurred
    The server responded with an error. The error message is in the JavaScript console.

    When i checked with console,
    got these following details :(



     
  7. Mike

    Mike XenForo Developer Staff Member

    That PHP error is a little weird and one I'll have to see if I can reproduce. It appears to be related to your max image dimensions; it seems they're set to weird values rather than blank or 0?

    You likely also want to disable debug mode.
     
    rbharathi likes this.

Share This Page