• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 error sending pm's

borgqueenx

Active member
#1
When i want to send pm's im greeted with th following error:
The following error occurred
The server responded with an error. The error message is in the JavaScript console.

Can someone please help me fix this?

The error only occurs when sending a pm with over about 100 characters. sending small pms with a couple of words still work for some reason.
 

Chris D

XenForo developer
Staff member
#2
If you open up the JavaScript console (usually F12 on your keyboard and then Console) does that have any details about the error? Is anything logged in your Admin CP Server Error Log?

Do you have any browser extensions installed, specifically related to blocking ads or JavaScript? If so, do you still get the error if you disable them?

Finally, do you have anything like mod_security installed on the server which may have been blocking any keywords in the Conversation title or content? Does disabling that allow you to continue?
 

Chris D

XenForo developer
Staff member
#4
I see an error there related to confetti.js. I assume that could be something to do with your Christmas stuff? It might be worth trying this all on a more default style (preferably the XF Default Style), or disable the confetti stuff just to eliminate that error being a problem.

I notice the HTML being returned in the JS error seems to have an "Error" in the <title> tag. If you scroll that down further can you see anywhere that might reveal what that error is?

Does this happen in all conversations to all users or just this conversation and this user? Is it affecting posting too?
 

borgqueenx

Active member
#5
it is not effecting posting.
I also notice it takes some loading time before the error is given in pm's.
The weird thing is that the length of pm's decides if it works or not. I can edit the pm afterwards and make it complete without problems.
The confetti is indeed showing a error, but it always has. I dont know how to disable it without removing the script all together. Besides this confetti has been there forever already, just on purpose made wrong (added DELETETHIS to the script) so it would not execute, so thats how it has been the last year.
 

Chris D

XenForo developer
Staff member
#6
With the length of the message seeming to be an issue, I wonder if it's related to post_max_size or max_input_vars, but really you would be experiencing the same issue everywhere if that was the case, and the defaults for these are usually more than sufficient. What length message is required to trigger the issue?

The only other thing that springs to mind is suhosin, which if it's enabled on the server you might want to try again with that disabled.

I'm still intrigued by the full message being returned. I have registered on your site if you can give me permission to start conversations I will look into it more closely.
 

borgqueenx

Active member
#7
With the length of the message seeming to be an issue, I wonder if it's related to post_max_size or max_input_vars, but really you would be experiencing the same issue everywhere if that was the case, and the defaults for these are usually more than sufficient. What length message is required to trigger the issue?

The only other thing that springs to mind is suhosin, which if it's enabled on the server you might want to try again with that disabled.

I'm still intrigued by the full message being returned. I have registered on your site if you can give me permission to start conversations I will look into it more closely.
i never heard of suhosin and dont think i have that installed on my VPS.
I have given you my guild member permission temporarily. Try to send a different streak of PM's to me (Konijntje on that site).
I have not yet asked other guild members to test this as well, but i did try a different browser myself.
Let me know what you find.
Thanks alot for wanting to help!
 

Chris D

XenForo developer
Staff member
#8
By the way, I still don't have the permission to start conversations so I have been unable to test this so far.
 

borgqueenx

Active member
#9
By the way, I still don't have the permission to start conversations so I have been unable to test this so far.
i apologise for the late reply and that it didn't work so far. You should be able to send PM's now. Please do so towards "Konijntje".
I was on a xmas holiday weekend ^^