1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Error on registration?

Discussion in 'Resolved Bug Reports' started by PVO_Dave, Jun 22, 2013.

  1. PVO_Dave

    PVO_Dave Active Member

    I'm trying to get a copy of what the user gets, but the server logs show:

    Mysqli statement execute error : Duplicate entry 'stopForumSpam_3ab092f2d6474854749139bdae39fa80ff6e294e' for key 'PRIMARY'

    Anything I can do or check whilst I wait for a copy of the user shown error? I believe the user is registering using an Android phone.

  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Check the log and post the full error message including the stack trace:

    Admin CP -> Tools -> Server Error Log
  3. PVO_Dave

    PVO_Dave Active Member

    Thanks Jake.

    #0 /var/www/vhosts/ukguitarforum.com/httpdocs/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
    #1 /var/www/vhosts/ukguitarforum.com/httpdocs/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
    #2 /var/www/vhosts/ukguitarforum.com/httpdocs/library/Zend/Db/Adapter/Abstract.php(574): Zend_Db_Adapter_Abstract->query('INSERT INTO `xf...', Array)
    #3 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/Model/SpamPrevention.php(465): Zend_Db_Adapter_Abstract->insert('xf_registration...', Array)
    #4 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/Model/SpamPrevention.php(146): XenForo_Model_SpamPrevention->_cacheRegistrationDecision('stopForumSpam_3...', 0)
    #5 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/Model/SpamPrevention.php(31): XenForo_Model_SpamPrevention->_checkSfsResult(Array, Object(Zend_Controller_Request_Http))
    #6 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/Model/SpamPrevention.php(23): XenForo_Model_SpamPrevention->_allowRegistration(Array, Object(Zend_Controller_Request_Http))
    #7 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/ControllerPublic/Register.php(267): XenForo_Model_SpamPrevention->allowRegistration(Array, Object(Zend_Controller_Request_Http))
    #8 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/FrontController.php(335): XenForo_ControllerPublic_Register->actionRegister()
    #9 /var/www/vhosts/ukguitarforum.com/httpdocs/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #10 /var/www/vhosts/ukguitarforum.com/httpdocs/index.php(13): XenForo_FrontController->run()
    #11 {main}
    Request State
    array(3) {
    ["url"] => string(52) "http://ukguitarforum.com/index.php?register/register"
    ["_GET"] => array(1) {
    ["register/register"] => string(0) ""
    ["_POST"] => array(14) {
    ["username"] => string(5) "james"
    ["email"] => string(26) "ukguitarforum@musXXX"
    ["password"] => string(8) "********"
    ["password_confirm"] => string(8) "********"
    ["dob_month"] => string(2) "1"
    ["dob_day"] => string(2) "2"
    ["dob_year"] => string(4) "1"
    ["gender"] => string(0) ""
    ["timezone"] => string(13) "Europe/London"
    ["recaptcha_challenge_field"] => string(185) "03AHJ_Vuv1uXqtwMjGTFjyp5iR8IdN2ahv0laGrsVrCe6C_tbPFrKIVSGGBYpog2Xe4WoOZee5s-THmMxNmGuXgEVxLAEuCh6tTFcu9e5JpyFTb2sGpFuy7vpk51T9VnebrjhJ4fuRJIOz4wcc-SabAfA3C4gbtPHCkRp0kSinxmA1eGlQnVLITis"
    ["recaptcha_response_field"] => string(10) "are inotsv"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "a90d1c5cde7bd88ba6dcaf4d87c9104b"

    I've amended the email address and DOB details.
  4. PVO_Dave

    PVO_Dave Active Member


    What the user gets
  5. Mike

    Mike XenForo Developer Staff Member

    Moved this to bugs to be looked at.
  6. PVO_Dave

    PVO_Dave Active Member

    Thanks Mike, I'll test with "Check DNSBL on registration" disabled if i can and report back
  7. Mike

    Mike XenForo Developer Staff Member

    Well, if you disable the StopForumSpam checks, it should prevent it. Some of the code surrounding this has changed for beta 2 though as is.
  8. PVO_Dave

    PVO_Dave Active Member

    Hi Mike,

    I tried disabling the option mentioned above, but he still got the error!

    He then tried an email without a hyphen and he could then register, hope that helps with testing etc ... :)

  9. Mike

    Mike XenForo Developer Staff Member

    This is fixed now. Fixed the error in question and a logic bug surrounding it.
    PVO_Dave likes this.
  10. PVO_Dave

    PVO_Dave Active Member

    Thanks Mike - I'll try and get it tested with the next beta release :)

  11. Sportsoutlaw

    Sportsoutlaw Member

    Is there a temp fix we can apply for this?
  12. Jeremy

    Jeremy XenForo Moderator Staff Member

    Yes, update.
    Sportsoutlaw and PVO_Dave like this.
  13. PVO_Dave

    PVO_Dave Active Member

    I was going to ask if this was fixed in the newly released Beta 2 - if so I'll update tonight and get it tested :)
  14. Sportsoutlaw

    Sportsoutlaw Member

    Yes, now that an update is available, LOL.
  15. Sportsoutlaw

    Sportsoutlaw Member

    Just an FYI, registrations still didn't work after updating to beta3. Cleared out the error logs, and tried again to reregister. Turns out, my error was coming from Taigachat, which I had disabled, but not uninstalled. Uninstalling the product removed the error that was blocking registration.
  16. PVO_Dave

    PVO_Dave Active Member

    Just to confirm this is now resolved after testing again on Beta3. Thanks for the swift work @Mike :)

Share This Page