1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

MG 1.1 Error message when uploading a video

Discussion in 'Media Gallery Support' started by Martok, Aug 21, 2015.

  1. Martok

    Martok Well-Known Member

    I've just got video uploads working on my site and I'm testing them to make sure all is OK.

    I uploaded a 5.5Mb .mp4 video with no problems and that plays as expected. I then tried uploading a 15Mb .mp4 video but each time I get this error:


    My upload limit is set to 40Mb.

    I've tried uploading the various videos and it seems that if the video is bigger than 8Mb I get this error message and below this the video will upload.

    I'm guessing that it's something that I'll need to get my web host to adjust but was hoping you'd know what the issue is so I can direct them appropriately
  2. Chris D

    Chris D XenForo Developer Staff Member

    I'm suspecting that your post_max_size value in php.ini is 8M (that's the default I think).
  3. Martok

    Martok Well-Known Member

    D'oh of course! I should have realised that, as I had to adjust the setting on another site a few years ago when using Moodle and I wanted bigger file uploads. It was the security error in the message that threw me.

    Thanks. :)
  4. Giray

    Giray Member

    So, on XFMG 1.1.2. I can upload a 3mb video, not a 32mb and not a 103mb. .mp4. All permissions are good and the detail tells me no limits on upload. My php is good; set at 256mb for both max size and upload. Not sure where else to look. Ideas?


    Guessing it's ffmpeg? Have to figure out how to configure it now.
  5. Chris D

    Chris D XenForo Developer Staff Member

    What is the actual error message?

    I know you've mentioned some PHP limits but I just want to be sure of the exact settings and their values. What is the upload_max_filesize and post_max_size settings in php.ini?

    ffmpeg is likely not involved, but knowing the exact message will make this clearer.
  6. Giray

    Giray Member

    256mb for both.
    Error message:

    The following error occurred
    There was a problem uploading your file.
    Adventure DNA - Getting Started - Long Version - v1b.mp4


    I've tried it with both .mp4 and a .mov h264
  7. Chris D

    Chris D XenForo Developer Staff Member

    That's not quite the error I was expecting; I think limit related errors are usually something else and, of course, you've already checked that.

    However, it's a very vague "unknown" error.

    What might be useful in the first instance is if you can disable the Flash uploader. You can do that in your own preferences, uncheck the "Use the Flash-based uploader to upload attachments".

    And then try again. Sometimes this gives a different or more descriptive error. Also keep an eye on your Server Error Log and your browser's console to see if any further information is logged there.
  8. Giray

    Giray Member

    Thanks Chris. Unfortunately, still no joy. Even with Flash uploader off, it won't upload. In this case no error message though. As for ffmpeg, I had 0.6.5 installed. My tech will install the latest version during our off-peak hours later today and will try again.
  9. Chris D

    Chris D XenForo Developer Staff Member

    That could be it, actually. But we do check the FFmpeg version, so you shouldn't have been allowed to actually save the option if the path you provided resolves to an outdated version.

    What happens if you go to Gallery Options > Video Options > and uncheck the "Enable FFmpeg features" box? Do uploads still fail, even with FFmpeg features disabled?
    Giray likes this.
  10. Giray

    Giray Member

    Yes, still fails. Last night we installed latest ffmpeg, but we have a compilation error. Recompiling tonight during lower load period. Will revert with results. But no, for now, I cannot upload anything over about 5 mb even though all the indicators show that I have unlimited upload privileges.
  11. Chris D

    Chris D XenForo Developer Staff Member

    Ok, so it's nothing to do with FFmpeg, as I suspected.

    If you were to allow the MP4 extension in Options > Attachments, can you upload the MP4 file to a post as an attachment or does it exhibit the same problem?
  12. Giray

    Giray Member

    So. Added mp4, increased the size of max attachments to 150mb (the file is 103) and still no joy, either as an attachment or as a media item in the gallery. sniff.
  13. Chris D

    Chris D XenForo Developer Staff Member


    This definitely implies it's related to some sort of limit in PHP or your webserver - at this point I'm thinking it could be the web server. It's not uncommon for some web servers (I think LightSpeed but I'm not certain and there's probably others) to override some of the php.ini files.

    I think with nginx you'd want to be looking at these values:

    You may also want to be looking at various logs - web server, PHP and MySQL error logs specifically. Aside from various limits, either one of these components could theoretically take exception to larger files.

    We're not even on to various server related add-ons yet... Things like suhosin have limits which could affect large file uploads:
  14. Giray

    Giray Member

    Sorry for the delayed response. So, mea culpa. It was a server-side problem. Bizarre, but php info was showing max file size at 256 but it was somehow actually set to 32. My server admin fixed it and it now works. Sorry for the false alarm!
    Chris D likes this.

Share This Page